Bug 428577 - SDL's pulseaudio hack not multilib-clean
SDL's pulseaudio hack not multilib-clean
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
: 428983 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-13 13:44 EST by Michel Alexandre Salim
Modified: 2008-01-22 10:47 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.2.13-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:47:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Changes to pulseaudio hack scripts (1.24 KB, patch)
2008-01-13 13:45 EST, Michel Alexandre Salim
no flags Details | Diff

  None (edit)
Description Michel Alexandre Salim 2008-01-13 13:44:01 EST
Description of problem:
The SDL RPM installs scripts into /etc/profile.d to set the audiodriver to esd
if pulseaudio is installed, because it currently does not support pulseaudio
directly.

There is a bug in both CSH and Bash scripts, however -- if on a multilib system,
both 32- and 64-bit versions of the ALSA pulseaudio driver are installed, the
Boolean expression does not evaluate properly. On TCSH it fails silently; on
Bash it reports:

bash: [: /usr/lib64/alsa-lib/libasound_module_pcm_pulse.so: binary operator expected

Version-Release number of selected component (if applicable):
SDL-1.2.12-5.fc8

How reproducible:
Always

Steps to Reproduce:
1. On an x86_64 system, install alsa-plugins-pulseaudio.i386
2. Start a new Bash / TCSH shell
3. printenv | grep SDL
  
Actual results:
With Bash, error result above. printenv reports nothing

Expected results:
No error; printenv reports SDL_AUDIODRIVER=esd

Additional info:
Patch attached.
Comment 1 Michel Alexandre Salim 2008-01-13 13:45:36 EST
Created attachment 291509 [details]
Changes to pulseaudio hack scripts

With this patch, the scripts test for /usr/lib/... and /usr/lib64/...
separately and || the result, so that they work when both drivers are installed
on a multilib system.
Comment 2 Thomas Woerner 2008-01-17 09:16:41 EST
*** Bug 428983 has been marked as a duplicate of this bug. ***
Comment 3 Michel Alexandre Salim 2008-01-17 09:18:11 EST

*** This bug has been marked as a duplicate of 426579 ***
Comment 4 Fedora Update System 2008-01-22 10:47:13 EST
SDL-1.2.13-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.