Bug 429116 - Configuration files being truncated in satellite
Configuration files being truncated in satellite
Status: CLOSED DUPLICATE of bug 427569
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Configuration Management (Show other bugs)
501
All Linux
low Severity low
: ---
: ---
Assigned To: Partha Aji
Steve Salevan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-17 09:09 EST by Nick Strugnell
Modified: 2009-02-19 11:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 03:29:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Strugnell 2008-01-17 09:09:34 EST
Description of problem:
When using the WebUI to edit configuration files, the entered configuration file
is truncated.

Version-Release number of selected component (if applicable):
5.0.1

How reproducible:
Intermittent

Steps to Reproduce:
1.Create a configuration channel
2.From the Channel Overview screen, select 'Add Files'
3.On the 'Add Files' submenu, select 'Create file'
4.On the next screen, type a file name and then some file contents in the large
textarea
5. Click the 'Create Configuration File' button

  
Actual results:
The saved file occasionally has the last few characters truncated. For example,
in one of our config files we have:

chage -d 0 root

as the last line.

This is always truncated to:

chage -d 0 r

Expected results:
No truncation should occur

Additional info:
There is no proxy in this configuration and the browser is running on the
satellite itself.

This is happening with short files (<1K)

Workaround is to add a comment as the last line of the file if possible as it
does not matter if this is truncated.
Comment 1 Nick Strugnell 2008-01-17 09:29:14 EST
OK, the culprit is the following line in the configuration file:

/usr/sbin/usermod -p '$1$yñ1üµßIA$2HQp.OK2aS9lMt20ApKKI/' linux

Without this line, we don't see any truncation.


Comment 2 Michael Mayer 2008-01-31 07:33:30 EST
That for sure is BZ#427569. The problem comes about by the use of UTF8
Characters in Configuration Files. This apparently was not foreseen in Satellite
5, but has been fixes in http://seg.rdu.redhat.com/scripts/hotfix/edit.pl?id=2489

Cheers,

Michael.
Comment 4 Nick Strugnell 2009-02-19 03:05:12 EST
Its definitely Bug 427569 - can close as a duplicate.
Comment 5 Jose Plans 2009-02-19 03:29:37 EST

*** This bug has been marked as a duplicate of bug 427569 ***

Note You need to log in before you can comment on or make changes to this bug.