Bug 429214 - Broken catalog with docbook-style-xsl-1.73.2-4.fc8
Broken catalog with docbook-style-xsl-1.73.2-4.fc8
Status: CLOSED DUPLICATE of bug 428531
Product: Fedora
Classification: Fedora
Component: docbook-style-xsl (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-17 17:53 EST by Behdad Esfahbod
Modified: 2008-01-18 16:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 04:28:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2008-01-17 17:53:05 EST
Description of problem:

After yum updating to docbook-style-xsl-1.73.2-4.fc8 I was left with a broken
XML catalog that held back my upstream package releases and wasted hours of my
time...  After spending 2 hours tracking down the problem I figured it's an rpm
issue...

Force erase and then installing the package fixed it.  Sigh...

Version-Release number of selected component (if applicable):

docbook-style-xsl-1.73.2-4.fc8
Comment 1 Ondrej Vasik 2008-01-18 04:28:11 EST
Sorry for that, but it was mentioned in update info:
"Correcting behaviour about removal of xml catalog registrations after release
drop from directory. (Those who already updated to
docbook-style-xsl-1.73.2-3.fc8 should first remove this package or force update
with this new package twice to correct registration of catalogs)".
Anyway, bug is caused purification changes requested by #389231 - real cause is
postun of docbook-style-xsl-1.73.2-3.fc8 which unregistered catalogs installed
in post of docbook-style-xsl-1.73.2-4.fc8, bug is duplicate of #428168 and
#428531  , closing DUPLICATE.

Once more time sorry for troubles...

*** This bug has been marked as a duplicate of 428531 ***
Comment 2 Behdad Esfahbod 2008-01-18 11:57:22 EST
I would have gone out of my way to avoid that in a stable release update...

And seriously, if you think people read update info, or are even supposed to,
that's really not the case.

Anyway, thanks for the response.
Comment 3 Ondrej Vasik 2008-01-18 16:00:27 EST
I agree with you, it was my fault - of course it was really bad idea to do such
change in stable release and I was not aware enough - I'm always testing my
updates, but in this case my common test was not enough - because problem occurs
in the next update after error. 

In fact there is easy solution - to make another update with a bit changed dir
name - which will cause the update from buggy release working without troubles
and should be harmless - but for the most people it is useless update - if they
already updated, it will have no additional value for them. 
Comment 4 Behdad Esfahbod 2008-01-18 16:26:46 EST
You can always check for the previously installed version in your %post to do
anything needed to fix the mess.  In fact I suggest you do that now.  The update
should have left thousands of machines with a broken docbook installation now...
 I see that reason enough to do another update.

Note You need to log in before you can comment on or make changes to this bug.