Bug 429233 - Miro crashes *after* playing a video. xine-lib.
Miro crashes *after* playing a video. xine-lib.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Thorsten Scherf
Fedora Extras Quality Assurance
:
: 429923 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-17 22:24 EST by Jason Farrell
Modified: 2008-01-24 16:53 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.1-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 16:53:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (8.40 KB, text/plain)
2008-01-17 22:24 EST, Jason Farrell
no flags Details
bugreport (104.65 KB, text/plain)
2008-01-18 18:27 EST, Dmitry Burstein
no flags Details

  None (edit)
Description Jason Farrell 2008-01-17 22:24:00 EST
Description of problem:
Miro crashes after successfully playing a video and attempting to go back to the
video list view. This began happening with the latest xine-lib updates.

Version-Release number of selected component (if applicable):
$ rpm -qa Miro\* xine-\*
xine-lib-devel-1.1.9.1-1.fc8
xine-lib-extras-1.1.9.1-1.fc8
Miro-debuginfo-1.0-2.fc8
xine-plugin-1.0-5.fc8
Miro-1.0-2.fc8
xine-lib-1.1.9.1-1.fc8
xine-lib-debuginfo-1.1.9.1-1.fc8
xine-lib-extras-nonfree-1.1.9.1-1.lvn8
xine-lib-arts-1.1.9.1-1.fc8
$ sudo tail -100 /var/log/yum.log | grep xine
Jan 16 17:08:42 Updated: xine-lib - 1.1.9.1-1.fc8.i386
Jan 16 17:08:43 Updated: xine-lib-extras - 1.1.9.1-1.fc8.i386
Jan 16 17:08:43 Updated: xine-lib-arts - 1.1.9.1-1.fc8.i386
Jan 16 17:08:44 Updated: xine-lib-extras-nonfree - 1.1.9.1-1.lvn8.i386
Jan 16 17:08:45 Updated: xine-lib-devel - 1.1.9.1-1.fc8.i386
Jan 17 21:58:12 Installed: xine-lib-debuginfo - 1.1.9.1-1.fc8.i386

How reproducible:
Always

Steps to Reproduce:
1. Play a video (using the default xine engine), and either wait for it to
finish play, or hit Stop.
  
Actual results:
Crash

Expected results:
Back to list view.

Additional info:
backtrace of relevant thread attached.
Comment 1 Jason Farrell 2008-01-17 22:24:00 EST
Created attachment 292103 [details]
backtrace
Comment 2 Dmitry Burstein 2008-01-18 18:27:28 EST
Created attachment 292224 [details]
bugreport

The same here.
Comment 3 Jason Farrell 2008-01-19 00:02:23 EST
Appears to be fixed in Miro 1.1
http://koji.fedoraproject.org/koji/buildinfo?buildID=31926
Comment 4 Alex Lancaster 2008-01-19 04:02:02 EST
Update is pending, please test when this goes to updates-testing:

https://admin.fedoraproject.org/updates/F8/pending/Miro-1.1-1.fc8
Comment 5 Dmitry Burstein 2008-01-19 11:09:58 EST
In 1.1 the bug seems to be solved.
Thanks.
Comment 6 Fedora Update System 2008-01-22 10:53:11 EST
Miro-1.1-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'
Comment 7 Alex Lancaster 2008-01-23 18:15:55 EST
*** Bug 429923 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2008-01-24 16:53:22 EST
Miro-1.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.