Bug 429389 - audio outputs in audacious 1.4.5-1 are in a bad shape.
audio outputs in audacious 1.4.5-1 are in a bad shape.
Product: Fedora
Classification: Fedora
Component: audacious (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ralf Ertzinger
Fedora Extras Quality Assurance
: 441459 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2008-01-18 22:16 EST by liang jian
Modified: 2008-11-26 13:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-11-26 12:53:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description liang jian 2008-01-18 22:16:28 EST
Description of problem:

    I recently updated audacious in my machine to 1.4.5-1. I found the audio
output plugin in the latest software were in bad shape now.

    1) PulseAudio Output Plugin: music playing is intermittent. now I hear sound
in one second and hear nothing in the next second.

    2) ESD Output Plugin: when I select this audio plugin in the preference
dialog audacious freezes.

    3) ALSA Output Plugin: 
       (3-1) hardware mixer mode: music playing works fine. But changing volume
in audacious will also affect other audio application in my fedora 8.

       (3-2) software mixer mode: music playing works fine. however, changing
volume has an incredible latency which is about 5 seconds.
Comment 1 Ralf Ertzinger 2008-01-21 16:05:20 EST
Regarding 1):
This (seems) to be a pulseaudio bug. Reducing the buffer size to 500 or less may

Regarding 2):
This is known, upstream work is under way. Please note that ESD does not exist
in a real sense any more in fedora, you get pulseaudio.

Regarding 3-1):
This is true, but is intended, as alsa does not support per-application mixers
in hardware

Regarding 3-2):
Because software mixing occurs before the alsa buffers there is a delay
proportional to the buffer size set in audacious. Again, reducing the buffer
size will fix this (at least partially)

I'm keeping this open because of 1) and 2)
Comment 2 liang jian 2008-01-22 08:05:01 EST
    Thanks for your explanation. 
    By reducing buffer size to 500 milliseconds, I can now play music normally
when using PulseAudio or ALSA output.
Comment 3 Jorge Fábregas 2008-01-23 06:57:49 EST

I just would like to confirm that I have the same symptoms as the original
reporter. I did an update this morning (of audacious & pulseaudio packages) and
have the same chopppy playback with pulseaudio here on F8. Not only that...I had
pulseaudio as default output plugin. After the update, the default output plugin
was changed to ALSA (without my intervention). 

I'm going to try suggested workaround.

Comment 4 Dag 2008-04-04 03:47:34 EDT
I just want to confirm that when choosing PulseAudio as output, the buffer size
must be inferior to 900ms otherwise the sound gets cut.
This gets really anoying when listeneing to some internet stream because a 900ms
buffer is clearly not enough. Same problem when the computer is under heavy
load, 900ms is not enough to avoid sound cuttings.
Comment 5 Ralf Ertzinger 2008-04-08 10:49:06 EDT
*** Bug 441459 has been marked as a duplicate of this bug. ***
Comment 6 Dag 2008-04-18 04:33:18 EDT
This bug has been marked as SOLVED in the 1.5.0 of Audacious.

I think this was reported here:

The reason I'm not sure of this link is because the Audcious' site (and their
bugzilla) suffers a database issue at this time, so I couldn't display that
bug's page anymore.

It was marked as 'SOLVED' few days ago in their bugzilla with Audacious 1.5.0.
Comment 7 Bug Zapper 2008-11-26 04:28:55 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 

Note You need to log in before you can comment on or make changes to this bug.