Bug 441459 - Audacious PulseAudio plugin is cutting sound
Audacious PulseAudio plugin is cutting sound
Status: CLOSED DUPLICATE of bug 429389
Product: Fedora
Classification: Fedora
Component: audacious-plugins (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ralf Ertzinger
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-08 04:24 EDT by Dag
Modified: 2008-04-08 10:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-08 10:49:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dag 2008-04-08 04:24:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv: Gecko/20080208 Fedora/ Firefox/

Description of problem:
The sound produced via the output plugin PulseAudio can gat awful:
I get something like less than 1 second of music, then silence, the music, then silence, ... as if there were buffer under-runs.
But this can't be a buffer under-run issue because the Audacious buffer is set to 3000ms (the default in Preferences>Audio), and my sound file is on the local HDD, and I use PulseAudio for all the multimedia applications that support it and only Audacious gets this issue.

I also found this out:
If I keep the buffer size in Audacious strictly under 1000ms, it's working fine, I've set it to 800ms, but now I'm getting buffer under-runs for internet streams.

If I increase the buffer to 1000ms or above I get something like 1 second of
music then 1 or more seconds without a sound or it just sounds crap (it depends
on which value I set for the buffer: the higher the number, the longer are the
So Pulse Audio plugin is nearly unusable in my case.

This buffer was previously set to 3000ms when I used the 1.3.x version of
Audacious, and working properly with the Pulse plugin.

On the Audacious web site, it says that when the sound is "cutted" one must
increase the buffer value... it seems that you must decrease it now.

here are the packages I installed:



Version-Release number of selected component (if applicable):
audacious-plugins 1.4.4-1

How reproducible:

Steps to Reproduce:
1. Install Audacious 1.4.5 with 1.4.4-1 plugins
2. configure Audacious to use PulseAudio as output
3. set a buffer size equal or above 1000ms
4. play a sound file

Actual Results:
The sound is cutted every second and even more often.
The higher the Audacious buffer value, the worse gets the sound and longer are the silences (sound occurs for less than 1 second every few seconds).

Expected Results:
sound should be without any cut.

Additional info:
So in Audacious I have two solutions when listening to a stream via PulseAudio:
- getting sound cutted because of buffer under-runs because of insufficient buffering
- getting sound cutted because of PulseAudio plugin.

This bug has once been reported here (Audacious plugins bugzilla):
that was a few months ago but there are no activity since then (only me confirming) and it's still marked new and unconfirmed.
Comment 1 Ralf Ertzinger 2008-04-08 10:49:04 EDT

*** This bug has been marked as a duplicate of 429389 ***

Note You need to log in before you can comment on or make changes to this bug.