Bug 429415 - BUG: unable to handle kernel paging request at virtual address 7c784b78
BUG: unable to handle kernel paging request at virtual address 7c784b78
Status: CLOSED DUPLICATE of bug 429412
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-19 11:16 EST by Martin Jürgens
Modified: 2008-01-22 19:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 19:25:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Jürgens 2008-01-19 11:16:42 EST
Description of problem:
Got my kernel oopsing while trying to play Need for Speed Underground 2 using wine.


Version-Release number of selected component (if applicable):
2.6.23.9-85.fc8

How reproducible:
Only happened one time and I am not able to reproduce it.


Additional info:

Jan 19 17:00:53 medora kernel: BUG: unable to handle kernel paging request at
virtual address 7c784b78
Jan 19 17:00:53 medora kernel: printing eip: c044543a *pde = 10056067 *pte =
1550b065 
Jan 19 17:00:53 medora kernel: Oops: 0003 [#1] SMP 
Jan 19 17:00:53 medora kernel: Modules linked in: snd_rtctimer nls_utf8 loop
truecrypt(F)(U) wlan_tkip(U) wlan_ccmp(U) vfat fat rfcomm l2cap bluetooth
autofs4 w83627ehf hwmon_vid sunrpc nf_conntrack_ipv4 ipt_REJECT iptable_filter
ip_tables nf_conntrack_ipv6 xt_state nf_conntrack nfnetlink xt_tcpudp
ip6t_ipv6header ip6t_REJECT ip6table_filter ip6_tables x_tables cpufreq_ondemand
dm_mirror dm_multipath dm_mod ipv6 snd_hda_intel snd_seq_dummy snd_seq_oss
snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss wlan_scan_sta(U)
snd_mixer_oss snd_pcm ath_rate_sample(U) nvidia(P)(U) parport_pc ath_pci(U)
wlan(U) parport ath_hal(P)(U) snd_timer snd_page_alloc k8temp hwmon
dvb_usb_dtt200u floppy dvb_usb pcspkr usb_storage snd_hwdep dvb_core snd button
i2c_nforce2 forcedeth soundcore i2c_core sg sr_mod cdrom pata_amd ata_generic
sata_nv libata sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd
Jan 19 17:00:53 medora kernel: CPU:    0
Jan 19 17:00:53 medora kernel: EIP:    0060:[<c044543a>]    Tainted: PF       VLI
Jan 19 17:00:53 medora kernel: EFLAGS: 00210246   (2.6.23.9-85.fc8 #1)
Jan 19 17:00:53 medora kernel: EIP is at cmpxchg_futex_value_locked+0x2a/0x3f
Jan 19 17:00:53 medora kernel: eax: 00000000   ebx: 7c784b78   ecx: 0000365d  
edx: fffffff2
Jan 19 17:00:53 medora kernel: esi: 00000000   edi: 00000000   ebp: cb495000  
esp: cb495e10
Jan 19 17:00:53 medora kernel: ds: 007b   es: 007b   fs: 00d8  gs: 003b  ss: 0068
Jan 19 17:00:53 medora kernel: Process speed2.exe (pid: 13917, ti=cb495000
task=c56c3840 task.ti=cb495000)
Jan 19 17:00:53 medora kernel: Stack: 7c784b78 00000000 c081ad18 c04458c2
c06161e1 cb495e5c cb495ea0 e0c37e00 
Jan 19 17:00:53 medora kernel:        cb495e80 e0c37e00 e17b3578 7c784b78
00000000 c56c3840 00000000 00000000 
Jan 19 17:00:53 medora kernel:        00000000 00000154 00000010 e10fbc00
c0641900 00000000 cb495f20 cb495edc 
Jan 19 17:00:53 medora kernel: Call Trace:
Jan 19 17:00:53 medora kernel:  [<c04458c2>] futex_lock_pi+0x182/0x986
Jan 19 17:00:53 medora kernel:  [<c06161e1>] unix_stream_sendmsg+0x152/0x2f7
Jan 19 17:00:53 medora kernel:  [<c05b19d5>] sock_aio_write+0xea/0xf6
Jan 19 17:00:53 medora kernel:  [<c0446f85>] do_futex+0x91c/0x959
Jan 19 17:00:53 medora kernel:  [<c0459312>] audit_syscall_exit+0x2aa/0x2c6
Jan 19 17:00:53 medora kernel:  [<c04470aa>] sys_futex+0xe8/0xfa
Jan 19 17:00:53 medora kernel:  [<c0407f4d>] do_syscall_trace+0xd7/0xde
Jan 19 17:00:53 medora kernel:  [<c040518a>] syscall_call+0x7/0xb
Jan 19 17:00:53 medora kernel:  =======================
Jan 19 17:00:53 medora kernel: Code: 00 57 56 89 d6 53 89 c3 89 e0 25 00 f0 ff
ff ff 40 14 89 da 83 c2 04 19 ff 39 50 18 83 df 00 85 ff ba f2 ff ff ff 75 08 89
f0 90 <0f> b1 0b 89 c2 89 e0 25 00 f0 ff ff ff 48 14 5b 89 d0 5e 5f c3 
Jan 19 17:00:53 medora kernel: EIP: [<c044543a>]
cmpxchg_futex_value_locked+0x2a/0x3f SS:ESP 0068:cb495e10
Jan 19 17:00:53 medora kernel: note: speed2.exe[13917] exited with preempt_count 1
Jan 19 17:00:53 medora kernel: BUG: sleeping function called from invalid
context at kernel/rwsem.c:20
Jan 19 17:00:53 medora kernel: in_atomic():1, irqs_disabled():0
Jan 19 17:00:53 medora kernel:  [<c04405d6>] down_read+0x12/0x28
Jan 19 17:00:53 medora kernel:  [<c04465d2>] futex_wake+0x19/0xb0
Jan 19 17:00:53 medora kernel:  [<c04466e8>] do_futex+0x7f/0x959
Jan 19 17:00:53 medora kernel:  [<c0423343>] fixup_exception+0xb/0x20
Jan 19 17:00:53 medora kernel:  [<c0620778>] do_page_fault+0x3e6/0x5ef
Jan 19 17:00:53 medora kernel:  [<c042d6d7>] __call_console_drivers+0x4f/0x5b
Jan 19 17:00:53 medora kernel:  [<c042da37>] release_console_sem+0x183/0x19c
Jan 19 17:00:53 medora kernel:  [<c04470aa>] sys_futex+0xe8/0xfa
Jan 19 17:00:53 medora kernel:  [<c04f65bf>] bad_put_user+0x0/0x9
Jan 19 17:00:53 medora kernel:  [<c042b770>] mm_release+0x81/0x87
Jan 19 17:00:53 medora kernel:  [<c042ee54>] exit_mm+0x12/0xdb
Jan 19 17:00:53 medora kernel:  [<c04301ea>] do_exit+0x215/0x6fc
Jan 19 17:00:53 medora kernel:  [<c0406822>] die+0x20c/0x242
Jan 19 17:00:53 medora kernel:  [<c06208b3>] do_page_fault+0x521/0x5ef
Jan 19 17:00:53 medora kernel:  [<c0620392>] do_page_fault+0x0/0x5ef
Jan 19 17:00:53 medora kernel:  [<c061f07a>] error_code+0x72/0x78
Jan 19 17:00:53 medora kernel:  [<c044543a>] cmpxchg_futex_value_locked+0x2a/0x3f
Jan 19 17:00:53 medora kernel:  [<c04458c2>] futex_lock_pi+0x182/0x986
Jan 19 17:00:53 medora kernel:  [<c06161e1>] unix_stream_sendmsg+0x152/0x2f7
Jan 19 17:00:53 medora kernel:  [<c05b19d5>] sock_aio_write+0xea/0xf6
Jan 19 17:00:53 medora kernel:  [<c0446f85>] do_futex+0x91c/0x959
Jan 19 17:00:53 medora kernel:  [<c0459312>] audit_syscall_exit+0x2aa/0x2c6
Jan 19 17:00:53 medora kernel:  [<c04470aa>] sys_futex+0xe8/0xfa
Jan 19 17:00:53 medora kernel:  [<c0407f4d>] do_syscall_trace+0xd7/0xde
Jan 19 17:00:53 medora kernel:  [<c040518a>] syscall_call+0x7/0xb
Jan 19 17:00:53 medora kernel:  =======================
Comment 1 Chuck Ebbert 2008-01-21 16:33:51 EST
Same as bug 429412 -- booting with the kernel option "noreplace-smp" will
prevent this oops.

And can you confirm this happened on a single-processor machine?
Comment 2 Chuck Ebbert 2008-01-22 19:25:57 EST

*** This bug has been marked as a duplicate of 429412 ***

Note You need to log in before you can comment on or make changes to this bug.