SSO (single sign-on) is being reconfigured. Maintenance started Jul 16 2:20PM UTC and will last 1 hour. Password-enabled login should still work.
Bug 429412 - System OOPS on soundserver crash
Summary: System OOPS on soundserver crash
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 8
Hardware: i686
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 429415 431823 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-19 15:13 UTC by milady
Modified: 2008-02-11 22:39 UTC (History)
3 users (show)

Fixed In Version: 2.6.23.15-137.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-11 22:39:14 UTC
Type: ---


Attachments (Terms of Use)
Soundserver crash window (85.93 KB, image/png)
2008-01-19 15:13 UTC, milady
no flags Details
Soundserver backtrace (2.20 KB, text/plain)
2008-01-19 15:13 UTC, milady
no flags Details
kernel OOPS trace (3.10 KB, text/plain)
2008-01-19 15:14 UTC, milady
no flags Details

Description milady 2008-01-19 15:13:09 UTC
Description of problem:
The arts soundserver crashes at the beginning of the KDE session. The moment I
click OK to close the window informing the crash, the system freezes (I think
it's a kernel oops) and it stops responding even to keyboard commands, I am
forced to shut it down using the power off button of the computer.


Version-Release number of selected component (if applicable):
kernel-2.6.23.9-85.fc8

How reproducible:
Always

Steps to Reproduce:
1.Start KDE session
2.
3.
  
Actual results:
System freeze

Expected results:
Working KDE session

Additional info:

Comment 1 milady 2008-01-19 15:13:09 UTC
Created attachment 292258 [details]
Soundserver crash window

Comment 2 milady 2008-01-19 15:13:53 UTC
Created attachment 292259 [details]
Soundserver backtrace

Comment 3 milady 2008-01-19 15:14:59 UTC
Created attachment 292260 [details]
kernel OOPS trace

If I leave the soundserver crash window alone, I can use the system just fine.
As soon as I try to close it or look at the backtrace, the kernel freezes.

Comment 4 milady 2008-01-21 15:57:17 UTC
Same as bug 391971, except mine triggers a kernel OOPS.

Comment 5 Chuck Ebbert 2008-01-21 20:00:34 UTC
Page protection violation.
Writing to a read-only page.

00000000 <.text>:
   0:   00 57 56                add    %dl,0x56(%edi)
   3:   89 d6                   mov    %edx,%esi
   5:   53                      push   %ebx
   6:   89 c3                   mov    %eax,%ebx
   8:   89 e0                   mov    %esp,%eax
   a:   25 00 f0 ff ff          and    $0xfffff000,%eax
   f:   ff 40 14                incl   0x14(%eax)
  12:   89 da                   mov    %ebx,%edx
  14:   83 c2 04                add    $0x4,%edx
  17:   19 ff                   sbb    %edi,%edi
  19:   39 50 18                cmp    %edx,0x18(%eax)
  1c:   83 df 00                sbb    $0x0,%edi
  1f:   85 ff                   test   %edi,%edi
  21:   ba f2 ff ff ff          mov    $0xfffffff2,%edx
  26:   75 08                   jne    0x30
  28:   89 f0                   mov    %esi,%eax
  2a:   90                      nop
===>
   0:   0f b1 0b                cmpxchg %ecx,(%ebx)
   3:   89 c2                   mov    %eax,%edx
   5:   89 e0                   mov    %esp,%eax
   7:   25 00 f0 ff ff          and    $0xfffff000,%eax
   c:   ff 48 14                decl   0x14(%eax)
   f:   5b                      pop    %ebx
  10:   89 d0                   mov    %edx,%eax
  12:   5e                      pop    %esi
  13:   5f                      pop    %edi
  14:   c3                      ret


Comment 6 Chuck Ebbert 2008-01-21 20:01:03 UTC
(In reply to comment #4)
> Same as bug 391971, except mine triggers a kernel OOPS.

Can you confirm this is a single-processor system?


Comment 7 Chuck Ebbert 2008-01-21 20:09:37 UTC
If you boot with the kernel option "noreplace-smp" does it prevent the kernel
OOPS when this happens?

Comment 8 milady 2008-01-21 20:16:31 UTC
My computer is a single-processor system (2 GHz Intel Pentium M).

Comment 9 milady 2008-01-21 20:21:25 UTC
(In reply to comment #7)
> If you boot with the kernel option "noreplace-smp" does it prevent the kernel
> OOPS when this happens?

No more kernel OOPS with this option. The soundserver still crashes though.

Comment 10 Chuck Ebbert 2008-01-23 00:25:58 UTC
*** Bug 429415 has been marked as a duplicate of this bug. ***

Comment 11 Chuck Ebbert 2008-01-23 00:32:24 UTC
Patch went in kernel 2.6.23.14-118.

Comment 12 Martin Jürgens 2008-01-23 14:53:45 UTC
> And can you confirm this happened on a single-processor machine?

Yes, AMD Sempron 3000+ with Cool 'n' Quiet activated on Asrock mainboard.

Comment 13 milady 2008-01-25 19:22:19 UTC
I think I know what may have caused the bug on my system: I'm using a webcam for
which the driver is not yet included in the kernel modules. I need the
OmniVision 519 driver and I compiled the version provided on www.rastageeks.org

Not having the webcam connected at startup solves the soundserver problem and
therefore the kernel oops...

Hope this helps

Comment 14 Chuck Ebbert 2008-02-08 00:19:39 UTC
*** Bug 431823 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2008-02-11 03:34:02 UTC
kernel-2.6.23.15-137.fc8 has been submitted as an update for Fedora 8

Comment 16 Fedora Update System 2008-02-11 22:38:47 UTC
kernel-2.6.23.15-137.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.