This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 429418 - [RHEL5 U2] Kernel BUG: soft lockup - CPU#1 stuck for 10s! [hald-probe-stor:2657]
[RHEL5 U2] Kernel BUG: soft lockup - CPU#1 stuck for 10s! [hald-probe-stor:2657]
Status: CLOSED DUPLICATE of bug 428945
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
http://rhts.lab.boston.redhat.com/cgi...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-19 11:36 EST by Jeff Burke
Modified: 2008-01-24 11:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 11:03:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-01-19 11:36:24 EST
Description of problem:
While trying to reserve ibm-x3200m2-01.rhts.boston.redhat.com using 
RHEL5.2-Server-20080117.1/2.6.18-70.el5 The system never boots . 
It gets stuck in a loop:
 BUG: soft lockup - CPU#1 stuck for 10s! [hald-probe-stor:2657]

Version-Release number of selected component (if applicable):
2.6.18-70.el5

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL5-Server-U1 or RHEL5.2-Server-20080117.1
2. Install 2.6.18-70.el5 kernel
3. Reboot
  
Actual results:
BUG: soft lockup - CPU#1 stuck for 10s! [hald-probe-stor:2657]

Pid: 2657, comm:      hald-probe-stor
EIP: 0060:[<c0561c38>] CPU: 1
EIP is at ide_do_request+0x2c4/0x6be
 EFLAGS: 00000246    Not tainted  (2.6.18-70.el5 #1)
EAX: da33a800 EBX: c07cbd14 ECX: 00000001 EDX: 00002988
ESI: c07cbd14 EDI: c07cbd14 EBP: da33a888 DS: 007b ES: 007b
CR0: 8005003b CR2: 0804a5d0 CR3: 1a8b0000 CR4: 000006d0
 [<c04d5552>] elv_queue_empty+0x1d/0x1e
 [<c05619f8>] ide_do_request+0x84/0x6be
 [<c042dcf0>] lock_timer_base+0x15/0x2f
 [<c042e1ab>] del_timer+0x41/0x47
 [<c04d5cbb>] elv_insert+0xc8/0x1ad
 [<c04d8262>] blk_execute_rq_nowait+0x6d/0x84
 [<c04d82f7>] blk_execute_rq+0x7e/0x9f
 [<c04d79a0>] blk_end_sync_rq+0x0/0x1d
 [<c04db638>] sg_io+0x253/0x338
 [<c04dbb59>] scsi_cmd_ioctl+0x1ab/0x356
 [<c04d79a0>] blk_end_sync_rq+0x0/0x1d
 [<e0979628>] ide_cdrom_check_media_change_real+0x1a/0x34 [ide_cd]
 [<e095b06e>] media_changed+0x40/0x6e [cdrom]
 [<c0476bdd>] check_disk_change+0x13/0x57
 [<e095f030>] cdrom_open+0x870/0x8b3 [cdrom]
 [<e095dcc1>] cdrom_ioctl+0x22/0xb21 [cdrom]
 [<c04be2e3>] avc_node_delete+0x23/0x2c
 [<c04be47a>] avc_alloc_node+0xf9/0x150
 [<c04be652>] avc_has_perm_noaudit+0x181/0x322
 [<c04be6b8>] avc_has_perm_noaudit+0x1e7/0x322
 [<e0979f46>] idecd_ioctl+0x12f/0x144 [ide_cd]
 [<c04bf37a>] avc_has_perm+0x3a/0x44
 [<c04d9ebb>] blkdev_driver_ioctl+0x4b/0x5b
 [<c04da4e6>] blkdev_ioctl+0x61b/0x669
 [<c04e25d2>] kobject_get+0xf/0x13
 [<c04bf37a>] avc_has_perm+0x3a/0x44
 [<c04bf971>] inode_has_perm+0x54/0x5c
 [<c04579ad>] filemap_nopage+0x192/0x315
 [<c046069c>] __handle_mm_fault+0x353/0x87b
 [<c04bf9f8>] file_has_perm+0x7f/0x88
 [<c0476b68>] block_ioctl+0x13/0x16
 [<c0476b55>] block_ioctl+0x0/0x16
 [<c047fbb0>] do_ioctl+0x1c/0x5d
 [<c047fe3b>] vfs_ioctl+0x24a/0x25c
 [<c047fe95>] sys_ioctl+0x48/0x5f
 [<c0404eff>] syscall_call+0x7/0xb
 =======================

Expected results:
System should boot normally

Additional info:
This looks to be machine specific. ibm-x3200m2-01.rhts.boston.redhat.com
Comment 1 Mike Gahagan 2008-01-22 13:41:48 EST
saw a similar message during the basic_sanity/boot_rhel5_kernels test with the
-72 vanilla x86_64 kernel on 


http://rhts.lab.boston.redhat.com/cgi-bin/rhts/test_log.cgi?id=1726171

system was hp-xw9400-01.rhts.boston.redhat.com
Comment 2 Mike Gahagan 2008-01-23 11:02:19 EST
Here is another softlockup.. this time found while running the LSPP test in RHTS.

http://rhts.lab.boston.redhat.com/cgi-bin/rhts/test_log.cgi?id=1731198
system in use was hp-xw9400-02.rhts.boston.redhat.com
Comment 3 Aristeu Rozanski 2008-01-24 11:03:24 EST
tested the patch from peterm and it solves the issue


*** This bug has been marked as a duplicate of 428945 ***

Note You need to log in before you can comment on or make changes to this bug.