Bug 429475 - ran yum update and cannot log into gnome anymore
ran yum update and cannot log into gnome anymore
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-20 16:34 EST by Joe Acosta
Modified: 2009-01-09 02:36 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:36:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xsession error log (3.72 KB, application/octet-stream)
2008-01-20 16:34 EST, Joe Acosta
no flags Details
full list of installed rpms (29.09 KB, text/plain)
2008-02-11 23:35 EST, Joe Acosta
no flags Details

  None (edit)
Description Joe Acosta 2008-01-20 16:34:59 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Evey time I log in

Steps to Reproduce:
1. I ran yum update last night.  
2. I started my computer today
3. I could not log into gnome, but kde worked.  
4. Looked at .xsession-errors and found error in .metacity directory where it
could not load the session
5. deleted .metacity directory
6. reconfigured desktop background, panel and panel icons and applets
7. One of the custom launchers will not save now and volume control no longer
works.  
8. system-config-soundcard show sound card.
  
Actual results:
Most of the desktop is back to what it was, but one of the custom launchers will
not save its value. It should be /usr/local/bin/tkn+ a wish script.  

Also the sound volume configuration wont change volume or bring up volumes.

Expected results:
Custom launcher should have correct icon and correct command and text it has
none, volume should work.

Additional info:
See attached xsession-errors file.

What is /apps/panel/applets/tomboy/prefs?
Comment 1 Joe Acosta 2008-01-20 16:34:59 EST
Created attachment 292300 [details]
xsession error log
Comment 2 Joe Acosta 2008-01-20 16:40:43 EST
Ok, just deleted .gstreamer* directories and I get:

No volume control GStreamer plugins and/or devices found. 

When I try to go into user prefs -> sound

when I hit test on any of the buttons I then get:

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink:
Internal GStreamer error: state change failed.  Please file a bug at
http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer.

so I am changing the volume part to gstreamer, but maybe I should file a
separate bug for the panel.
Comment 3 Joe Acosta 2008-01-21 23:59:31 EST
I found out the issue with the volume is that there is no group "audio" anymore
in the /etc/group file.

Also the also udev rules are missing a GROUP="audio" in it also.

so the udev rules ( 40-alsa.rules ) have:

    KERNEL=="controlC[0-9]*",	NAME="snd/%k"

but need:

    KERNEL=="controlC[0-9]*",	NAME="snd/%k", GROUP="audio"

in order for a user in the group audio to run work with sound
Comment 4 Joe Acosta 2008-01-23 00:58:48 EST
I'm changing the priority on this to high as I can no longer long into the GNOME
and after deleting what I thought was all the config files for gnome, it still
does not allow me to log into gnome.  

Comment 5 Seth Vidal 2008-01-23 01:07:22 EST
removing the yum people
Comment 6 Joe Acosta 2008-01-23 11:50:17 EST
Ok, I have filed a separate bug about the udev rules
(https://bugzilla.redhat.com/show_bug.cgi?id=429886) that are causing gstreamer
not to work.  It should be simple to fix that issue IMHO, but I'm sure it will
turn into a mountain.  Comments #2 and #3 have been moved to but #429886.

I have changed this bug from gstreamer to gnome-desktop.  I am not sure what is
going on with it.  If I delete .gconf, .gconfd, .metacity, .nautilus , and a few
other configuration directories, I can sometimes log in.  Usually though
nautilus fails after that.  It has become unusable. I was able to use it for a
few days and then suddenly it went south.  

Let me know what I can do to help solve this.  I want my desktop back.  
Comment 7 Ray Strode [halfline] 2008-02-11 17:43:09 EST
is ConsoleKit installed and running?
Comment 8 Joe Acosta 2008-02-11 23:35:55 EST
Created attachment 294624 [details]
full list of installed rpms
Comment 9 Joe Acosta 2008-02-11 23:41:31 EST
rpm -qa|grep -i consolekit

ConsoleKit-x11-0.2.3-1.fc8
ConsoleKit-0.2.3-1.fc8
ConsoleKit-libs-0.2.3-1.fc8

they are installed:

/sbin/service ConsoleKit status
console-kit-daemon is stopped

it is not running.

I've deleted just about every config file that I can find for gnome and
nautilus, including .gnome .gnome2 and .nautilus and several other directories.

I am now able to log in and have set some preferences up.  Seems to be working
at a minimum changed configuration.  

I have one panel as I deleted one panel.  I have not added a color or
transparency to the panel, nor have I added any custom launchers.  Nor have I
added gnome-swallow applet to swallow wmcpublue applet.  

I have not turned off the screenssaver or changed it.  Normally I select one the
planets. Normally I also do not require a login to the system because it is at
home and I trust people I let into my home, however I have not changed that for
fear I will not be able to log in again.

What is ConsoleKit for and do I need it running?    
Comment 10 Ray Strode [halfline] 2008-02-12 00:24:51 EST
ConsoleKit is an essential part of the environment.  It's got to be running for
things to function properly.

If you 

/sbin/chkconfig ConsoleKit on
/sbin/service ConsoleKit start

do things start behaving better?  It should clear up your audio problems (since
it tells HAL to give you permissions to your audio device.  It may fix some of
your other problems as well.
Comment 11 Joe Acosta 2008-02-12 00:38:32 EST
ok, changing the udev rules fixed the audio issue

after starting this I notice no difference.. I still can't mount usb drives
unless I log in as root, not sure how this affect gnome...
Comment 12 Ray Strode [halfline] 2008-02-12 10:30:12 EST
So it seems you have a number of different issues. Can you file each one as
separate reports?

1) permissions on audio devices are wrong (that one is fixed by ConsoleKit
running.  You shouldn't need to be in an "audio" group to have working sound)

2) an issue with gstreamer

3) problems logging in

4) problems mounting usb drives

5) custom launcher not being remembered across logins?
Comment 13 Joe Acosta 2008-02-12 23:35:56 EST
The gstreamer issue was because of #1.  I've deleted the audio group, lets see
how that works.  

What component do I put for 3, 4, and 5?
Comment 14 Ray Strode [halfline] 2008-02-13 10:08:56 EST
3 should go to gnome-session, 4 could be gnome-volume-manager, gnome-mount, or
HAL i guess (they're all owned by the same person though, so just pick one). 5
goes to gnome-panel.
Comment 15 Joe Acosta 2008-02-16 23:37:08 EST
problem #4 went away with the running of ConsoleKit also, and #3 also seems to
have gone away after deleting all the config files and setting up the system
again.  I will test #3 again and #5 custom launchers tomorrow.
Comment 16 Bug Zapper 2008-11-26 04:30:08 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Bug Zapper 2009-01-09 02:36:27 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.