Bug 429704 - disable dns_sd explicitly
disable dns_sd explicitly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdelibs (Show other bugs)
5.1
All Linux
medium Severity low
: rc
: ---
Assigned To: Ngo Than
desktop-bugs@redhat.com
:
: 454224 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-22 10:20 EST by Michal Babej
Modified: 2013-07-31 19:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-27 04:30:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Babej 2008-01-22 10:20:08 EST
Description of problem:
if package avahi-compat-libdns_sd-devel is installed on the machine, that
enables   DNS_SD support during build time & building fails. 

DNS_SD support was never enabled in kdelibs for RHEL5.

So this is a request to add "--disable-dnssd" option to the configure in
specfile to disable the feature explicitly.
Comment 1 Ngo Than 2008-01-22 10:24:30 EST
+devel
Comment 3 Michal Babej 2008-07-07 10:49:27 EDT
*** Bug 454224 has been marked as a duplicate of this bug. ***
Comment 4 Michal Babej 2008-07-07 10:53:10 EDT
Actually bug 454224 has a patch to build clearly with dns_sd, if i understand it
correctly. I haven't tried it, though. I'm fine with either solution as long as
kdelibs builds.
Comment 5 Vic 2008-07-07 11:59:41 EDT
It's a *trivial* patch (change "char *" to "unsigned char *" in prototype, and
one cast). If it works without the avahi thing, I'd recommend it.

I've only built it as in bug 454224 - it's taking about 9 hours to build on my
old Duron build machine, so I'm not redoing it :-)
Comment 16 errata-xmlrpc 2008-08-27 04:30:12 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0811.html

Note You need to log in before you can comment on or make changes to this bug.