Bug 454224 - kdelibs won't build on EL5 platform
kdelibs won't build on EL5 platform
Status: CLOSED DUPLICATE of bug 429704
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdelibs (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Ngo Than
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-06 18:38 EDT by Vic
Modified: 2008-07-07 10:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-07 10:49:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trivial patch to correct build error (1.21 KB, patch)
2008-07-06 18:38 EDT, Vic
no flags Details | Diff
.spec file to use that patch (54.00 KB, text/plain)
2008-07-06 18:40 EDT, Vic
no flags Details

  None (edit)
Description Vic 2008-07-06 18:38:13 EDT
Description of problem:
Building kdelibs on an EL5 platform fails with a signedness error.

Version-Release number of selected component (if applicable):
3.5.4-16.el5


How reproducible:
Easily.


Steps to Reproduce:
1. Build the EL5 avahi SRPM (there's only one on the FTP site)
2. Install the RPMs that ensue
3. Try to rebuild the kdelibs SRPM 
  
Actual results:
Build fails with an error:
remoteservice.cpp:105: error: invalid conversion from 'void
(*)(_DNSServiceRef_t*, DNSServiceFlags, uint32_t, DNSServiceErrorType, const
char*, const char*, uint16_t, uint16_t, const char*, void*)' to 'void
(*)(_DNSServiceRef_t*, DNSServiceFlags, uint32_t, DNSServiceErrorType, const
char*, const char*, uint16_t, uint16_t, const unsigned char*, void*)'

Expected results:
Successful build


Additional info:
This is KDE bug #134212 - see http://bugs.kde.org/show_bug.cgi?id=134212 . The
attachment marked as id=17809 corrects the build - the longer patch from SVN
commit 616448 might be more appropriate - but I didn't test it.
Comment 1 Vic 2008-07-06 18:38:13 EDT
Created attachment 311106 [details]
trivial patch to correct build error
Comment 2 Vic 2008-07-06 18:40:03 EDT
Created attachment 311107 [details]
.spec file to use that patch

This seems to build (at least, it's still building - the supplied build fails
some hours earluer).
Comment 3 Vic 2008-07-06 18:42:25 EDT
Bugzilla has erroneously linked this to RH bug #134212; my link was to the KDE
bug of the same number.

This has nothing whatsoever to do with RH bug #134212.
Comment 4 Michal Babej 2008-07-07 10:49:26 EDT

*** This bug has been marked as a duplicate of 429704 ***

Note You need to log in before you can comment on or make changes to this bug.