Bug 430081 - Please rebuild speex for EPEL 4 and 5
Please rebuild speex for EPEL 4 and 5
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: speex (Show other bugs)
5.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 430082
  Show dependency treegraph
 
Reported: 2008-01-24 08:53 EST by Robert Scheck
Modified: 2008-01-25 02:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-25 02:28:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-01-24 08:53:29 EST
Description of problem:
Please rebuild speex for EPEL 4 and 5

Version-Release number of selected component (if applicable):
speex-1.2-0.3.beta2

Actual results:
No speex in EPEL 4 and 5

Expected results:
Package speex in EPEL 4 and 5

Additional info:
Please let me know, when you're not interested in maintaining the package 
there.
Comment 1 Robert Scheck 2008-01-24 09:09:48 EST
The package seems to build (and work) on EPEL:

Wrote: /builddir/build/RPMS/speex-1.2-0.3.beta2.x86_64.rpm
Wrote: /builddir/build/RPMS/speex-devel-1.2-0.3.beta2.x86_64.rpm
Wrote: /builddir/build/RPMS/speex-debuginfo-1.2-0.3.beta2.x86_64.rpm
Comment 2 Jeffrey C. Ollie 2008-01-24 09:13:04 EST
Speex is not in EPEL because it is in the base RHEL OS, but at an older version
(1.0.5 IIRC).  Some of the features in the Asterisk package require Speex 1.2. 
EPEL has a policy of not overriding anything in the base RHEL OS.  The best
solution would be for the Speex in RHEL to be upgraded to 1.2 but that's not
likely to happen because of RHEL's policies.
Comment 3 Marcela Mašláňová 2008-01-24 09:20:01 EST
[1] You can maintain it in EPEL, but we don't have the review of the package.
I'look at it.
Comment 4 Robert Scheck 2008-01-24 09:25:39 EST
As I was pointed from Jeffrey, that the package already exists in RHEL: Please 
update speex in RHEL to something more up2date (and sometimes it is done even 
for RHEL so I'm requesting this hereby).

RHEL4: speex-1.0.4-4
RHEL5: speex-1.0.5-4

I would like to see them at speex-1.2-0.3.beta2 niveau around, if possible...
Comment 5 Marcela Mašláňová 2008-01-24 09:33:04 EST
I don't see any issue tracker. Please ask your support.

I'm not sure if it won't hurt linephone and other tools using speex.
Comment 6 Robert Scheck 2008-01-24 14:34:47 EST
That's why I'm nice asking. I would like to see Asterisk in EPEL, but this 
requires a newer speex - it IMHO won't help to ask the support, because it's 
something unsupported.

Jeffrey, could you live with a "compat" package called "speex-compat", "compat-
speex" or similar? But then this would have library name changes as well, or am 
I wrong? And as far as I can see, this also requires patching asterisk then to 
pick this separate package up somehow :-(
Comment 7 Jeffrey C. Ollie 2008-01-24 16:46:17 EST
This was discussed on the epel-devel list a few weeks ago, and the general
consensus seemed to be against adding a compat package, especially since it
would just be for EPEL.
Comment 8 Robert Scheck 2008-01-24 17:50:12 EST
Won't fix because of RHEL policies :-( Please close this bug report, as I'm 
somehow not allowed to do this (even as owner)
Comment 9 Marcela Mašláňová 2008-01-25 02:28:05 EST
Couldn't we add newer speex somehow into EPEL asterisk. I know that asterisk is
often used and it's shame that EPEL haven't chance to support it.

Closing it -> can't fix, because jumping on higher version could ruined other
related packages.

Note You need to log in before you can comment on or make changes to this bug.