Bug 430098 - traceback when transitioning to stage#2 - rhpxl - IndentationError: expected an indented block
traceback when transitioning to stage#2 - rhpxl - IndentationError: expected ...
Status: CLOSED DUPLICATE of bug 430074
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhpxl (Show other bugs)
5.2
All Linux
medium Severity low
: rc
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-24 10:04 EST by James Laska
Modified: 2013-09-02 02:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 10:12:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2008-01-24 10:04:38 EST
Description of problem:

Booting the installer fails when transitioning to stage#2

Version-Release number of selected component (if applicable):

RHEL5.2-Server-20080124.nightly/i386
 * rhpxl-0.41.1-1.el5
 * anaconda-11.1.2.90-1

How reproducible:
%100 on HP system

Steps to Reproduce:
1. Boot installer using kickstart or manually step through loader
  
Actual results:

Traceback in anaconda:

File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 743
   print _("Found HP Virtual Mouse")
        ^^^^^
IndentationError: expected an indented block

The surrounding code indicates that the "print" stmt should be indented into the
if conditional block?

        ## Check for HP iLO 2 virtual mouse and if it exists configure evdev
        ilomousehw = ilomouse.ilomouseCheck()
        if ilomousehw.isDevicePresent():
        print _("Found HP Virtual Mouse")
            ilomouse_conf = xf86config.XF86ConfInput()
            xconfig.input.insert(ilomouse_conf)
            ilomouse_conf.identifier = "ilomouse"

Expected results:

 - No traceback

Additional info:
Comment 1 Chris Lumens 2008-01-24 10:12:49 EST

*** This bug has been marked as a duplicate of 430074 ***

Note You need to log in before you can comment on or make changes to this bug.