Bug 430074 - xhwstate.py: line 743: IndentationError: expected an indented block
xhwstate.py: line 743: IndentationError: expected an indented block
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhpxl (Show other bugs)
5.2
All Linux
high Severity high
: beta
: ---
Assigned To: Adam Jackson
:
: 430098 430581 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-24 07:52 EST by Milan Zazrivec
Modified: 2008-05-21 12:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0383
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:48:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhpxl patch (837 bytes, patch)
2008-01-28 04:01 EST, Milan Zazrivec
no flags Details | Diff

  None (edit)
Description Milan Zazrivec 2008-01-24 07:52:39 EST
Description of problem:
File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py" contains
line with wrong identation.

Version-Release number of selected component (if applicable):
rhpxl-0.41.1-4.el5

How reproducible:
Always

Steps to Reproduce:
1. python "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py"
  
Actual results:
File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 743
    print _("Found HP Virtual Mouse")
        ^
IndentationError: expected an indented block

Additional info:
Mentioned error prevents RHEL5.2-Server-20080124.nightly from being installed
(via anaconda) on a machine connected to a KVM switch.
Comment 1 Chris Lumens 2008-01-24 10:12:50 EST
*** Bug 430098 has been marked as a duplicate of this bug. ***
Comment 2 Milan Zazrivec 2008-01-28 04:01:14 EST
Since RHEL5.2 anaconda imports rhpxl module, mentioned identation error
prevents all RHEL5.2 composes to be installed (stage2 throws python exception).

This error should be fixed ASAP.
Comment 3 Milan Zazrivec 2008-01-28 04:01:56 EST
Created attachment 293139 [details]
rhpxl patch
Comment 6 Kristian Høgsberg 2008-01-28 15:49:31 EST
Fix committed, building as rhpxl-0.41.1-5.el5.src.rpm.
Comment 7 Kristian Høgsberg 2008-01-28 16:19:25 EST
Adding dev ack.
Comment 10 Kevin E. Martin 2008-02-06 10:33:01 EST
*** Bug 430581 has been marked as a duplicate of this bug. ***
Comment 12 errata-xmlrpc 2008-05-21 12:48:33 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0383.html

Note You need to log in before you can comment on or make changes to this bug.