This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 430152 - plugins with no configure ability do not grey out the configure button
plugins with no configure ability do not grey out the configure button
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 430561 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-24 16:00 EST by Scott R. Godin
Modified: 2008-01-29 04:52 EST (History)
2 users (show)

See Also:
Fixed In Version: evolution-2.21.5-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-25 04:37:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 461272 None None None Never

  None (edit)
Description Scott R. Godin 2008-01-24 16:00:55 EST
Description of problem:

Usability issue: all the plugins that are available from Edit>Plugins have the 
'configure' button available/enabled even if there are no configurable 
options. 


Version-Release number of selected component (if applicable):
evolution-2.12.3-1.fc8

How reproducible:
every time

Steps to Reproduce:
1. open Edit:Plugins
2. click the 'configure' button on any plugin that has no configurable options 
(most of them)

  
Actual results: 
nothing happens, and user is left wondering if there was an error or failure 
to either display an error message, a warning that there are no config 
options, or whether there are no config options


Expected results:
configure button should 'grey out' when any plugin has no configure dialog for 
options


Additional info:
Comment 1 Milan Crha 2008-01-25 04:37:17 EST
Thanks for report. This has been fixed upstream, see [1], but wasn't pushed to
stable, so it missed Fedora 8. Anyway, in [2] this was dropped and new Evolution
(stable since 2.22 (version synced with gnome)) uses configuration tab, not the
button.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=461272
[2] http://bugzilla.gnome.org/show_bug.cgi?id=500210
Comment 2 Milan Crha 2008-01-29 04:52:19 EST
*** Bug 430561 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.