Bug 430177 - clamd.d/amavisd.conf configuration directives require boolean arguments [NEEDINFO]
clamd.d/amavisd.conf configuration directives require boolean arguments
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: amavisd-new (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Juan Orti
Fedora Extras Quality Assurance
ActualBug
:
: 459954 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-24 19:48 EST by Ray Van Dolson
Modified: 2015-11-28 22:24 EST (History)
4 users (show)

See Also:
Fixed In Version: amavisd-new-2.5.2-3.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-28 22:24:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
johan-fedora: needinfo? (steve)


Attachments (Terms of Use)
Patch to fix the problems. (560 bytes, patch)
2010-04-03 12:33 EDT, Michael Arnold
no flags Details | Diff

  None (edit)
Description Ray Van Dolson 2008-01-24 19:48:04 EST
After installing amavisd-new-2.4.5-1.el5 from epel-testing I get the following
when running service clamd.amavisd start:

# service clamd.amavisd start
Starting clamd.amavisd: ERROR: Parse error at line 2: Option LogSyslog requires
boolean argument.
ERROR: Can't open/parse the config file /etc/clamd.d/amavisd.conf
                                                           [FAILED]

Turns out FixStaleSocket also requires a boolean argument.

I appended a 'yes' to both of these configuration directives and everything is
working fine now.

This is in tandem with clamav-server-0.92-4.1.el5 from epel.
Comment 1 Ray Van Dolson 2008-01-24 19:49:25 EST
Note: You may want to check this with EL4 as well.  I don't have one handy to
test with at the moment.
Comment 2 Ray Van Dolson 2008-02-29 02:28:29 EST
Ping?
Comment 3 Steven Pritchard 2008-03-01 14:45:24 EST
Sorry for the delay.  This will be fixed as soon as I am able to upgrade the
amavisd-new in EPEL to something current.  The last time I worked on this, we
were still missing some dependencies.
Comment 4 Johan Kok 2008-07-08 10:50:27 EDT
Steven, is this issue still present?
Comment 5 jlquinn 2008-12-07 00:13:54 EST
Yes, it's present.  I just installed amavisd-new again and see the same problem in /etc/clamd.d/amavisd.conf
Comment 6 Michael Arnold 2010-04-03 12:33:15 EDT
Created attachment 404312 [details]
Patch to fix the problems.

Attached is a patch to fix the problems.
Comment 7 Johan Kok 2011-06-09 01:31:08 EDT
*** Bug 459954 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2014-08-07 05:49:06 EDT
amavisd-new-2.5.2-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/amavisd-new-2.5.2-3.el5
Comment 9 Fedora Update System 2014-08-07 20:40:59 EDT
Package amavisd-new-2.5.2-3.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing amavisd-new-2.5.2-3.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2152/amavisd-new-2.5.2-3.el5
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2015-11-28 22:23:57 EST
amavisd-new-2.5.2-3.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.