Bug 430264 - qdisk master abdication does not work correctly in all cases
qdisk master abdication does not work correctly in all cases
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Lon Hohberger
GFS Bugs
:
: 468144 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-25 11:45 EST by Lon Hohberger
Modified: 2009-04-16 18:56 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0347
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:58:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix (709 bytes, patch)
2008-01-25 11:45 EST, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2008-01-25 11:45:36 EST
Description of problem:

When qdiskd detects multiple masters, all detecting qdiskd instances are
supposed to abdicate their position and elect a new master.  Unfortunately, a
logic error prevents this from occurring in all cases.  For example, if qdiskd
goes to sleep, is evicted, and still thinks it is master, it will complain:

"A master exists, but it's not me?!"

Steps to Reproduce: Unknown; seen in overnight testing
  
Actual results:  Loop with annoying messages

Expected results: Master abdication + re-election
Comment 1 Lon Hohberger 2008-01-25 11:45:36 EST
Created attachment 292960 [details]
Fix
Comment 2 Lon Hohberger 2008-02-04 12:19:12 EST
One way to cause this is to corrupt the quorum disk while qdiskd is running.
Comment 3 Lon Hohberger 2008-03-04 17:34:13 EST
This is in my local git branch and has already been pushed to master.
Comment 12 errata-xmlrpc 2008-05-21 11:58:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0347.html
Comment 13 Lon Hohberger 2008-12-03 13:20:43 EST
*** Bug 468144 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.