Bug 430314 - /etc/init.d/ipa_webgui reports "OK" start when it fails to start a webgui daemon
/etc/init.d/ipa_webgui reports "OK" start when it fails to start a webgui daemon
Status: CLOSED DUPLICATE of bug 430011
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-25 20:06 EST by Michael Gregg
Modified: 2015-01-04 18:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 17:49:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Gregg 2008-01-25 20:06:01 EST
Description of problem:

when ipa_webgui fails to launch daemon it fails to report a error. 

Version-Release number of selected component (if applicable):
build from 1-24-08
easily observered on:
http://apoc.dsdev.sjc.redhat.com/tet/results/FC7/i386/2008-01-25_03_01-build/ipa.repo

How reproducible:
always when the deamon fails to run.

Steps to Reproduce:
1. Install a broken version of ipa.
2. configure it with ipa-server-install
3. run /etc/init.d/ipa_webgui restart
  
Actual results:
the stop fails, but the start reports "OK"

Expected results:
the start to report "FAIL" because the daemon didn't start.
Comment 1 Rob Crittenden 2008-01-29 17:49:17 EST

*** This bug has been marked as a duplicate of 430011 ***

Note You need to log in before you can comment on or make changes to this bug.