This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 430011 - ipa-webgui init script should verify that ipa-webgui started successfully
ipa-webgui init script should verify that ipa-webgui started successfully
Status: CLOSED ERRATA
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
: 430314 430316 (view as bug list)
Depends On:
Blocks: freeipa10 429034
  Show dependency treegraph
 
Reported: 2008-01-24 01:44 EST by Chandrasekar Kannan
Modified: 2012-03-27 03:19 EDT (History)
5 users (show)

See Also:
Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Add debug, foreground flags. Enable logging in script to catch startup errs (2.99 KB, patch)
2008-01-30 11:57 EST, Rob Crittenden
no flags Details | Diff

  None (edit)
Description Chandrasekar Kannan 2008-01-24 01:44:27 EST
Ticket #95 (assigned defect)

Opened 2 months ago

Last modified 2 months ago
ipa-webgui init script should verify that ipa-webgui started successfully
Reported by: 	kmacmill 	Assigned to: 	kmacmill (accepted)
Priority: 	major 	Milestone: 	release-1
Component: 	ipa-server 	Version: 	
Keywords: 		Cc: 	
Description ¶

The init script does not seem to check errors properly - it is possible for the web gui to silently fail.
Change History
2007-11-14 08:39:46 changed by kmacmill ¶

    * status changed from new to assigned.
    * milestone changed from milestone-5 to release-1.
Comment 1 Rob Crittenden 2008-01-29 17:49:18 EST
*** Bug 430314 has been marked as a duplicate of this bug. ***
Comment 2 Rob Crittenden 2008-01-30 11:57:00 EST
Created attachment 293450 [details]
Add debug, foreground flags. Enable logging in script to catch startup errs

Some errors aren't detected until the server receives its first request
(something already using the port, for example).

This patch adds logging during startup so it should be easier to track down
errors.

Also a -f flag for preventing the script from becoming a daemon and -d flag for
increasing the debug level of the log.
Comment 3 Rob Crittenden 2008-01-30 15:10:59 EST
Committed in changeset 610
Comment 6 Rob Crittenden 2008-01-31 11:40:24 EST
*** Bug 430316 has been marked as a duplicate of this bug. ***
Comment 7 Chandrasekar Kannan 2008-04-16 12:48:11 EDT
will verify this in the post-beta cycle. I have verified that
the webgui functions ok though...
Comment 8 Yi Zhang 2008-05-22 17:59:41 EDT
What is the right behave of ipa_webgui script?

When stop ipa_webgui service, and run "ipa_webgui" directly, there is no message
output at all, even when i do "ipa_webgui -d".

Shall we output something to notify user the status of ipa-webgui? 
Comment 9 Rob Crittenden 2008-05-23 08:44:06 EDT
No, ipa_webgui is a daemon. If you want output you have to run it in foreground
mode with -f.
Comment 10 Yi Zhang 2008-05-23 18:52:19 EDT
QA Verified on May 23, 2008 (Yi)

Build used: May 23, 2008 (x64)

Note You need to log in before you can comment on or make changes to this bug.