Bug 430358 - Buffer I/O errors on TWO SD cards
Buffer I/O errors on TWO SD cards
Status: CLOSED DUPLICATE of bug 188544
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-26 15:37 EST by Luis A. Florit
Modified: 2008-02-11 18:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-11 18:57:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis A. Florit 2008-01-26 15:37:21 EST
Description of problem:
I am getting Buffer I/O errors trying to mount _TWO_ SD cards (that until just 
2 weeks ago never had any issues) using a card reader.

Version-Release number of selected component (if applicable):
udev-118-1.fc8

How reproducible:
I plug the SD card, and after several tries, the card is ejected (mount: 
special device /dev/sdb1 does not exist)

  
Actual results:
This is what I have in dmesg:

Buffer I/O error on device sdb1, logical block 3969792
Buffer I/O error on device sdb1, logical block 3969793
Buffer I/O error on device sdb1, logical block 3969794
sd 12:0:0:0: [sdb] 3970048 512-byte hardware sectors (2033 MB)
sd 12:0:0:0: [sdb] Write Protect is off
sd 12:0:0:0: [sdb] Mode Sense: 03 00 00 00
sd 12:0:0:0: [sdb] Assuming drive cache: write through
sd 12:0:0:0: [sdb] 3970048 512-byte hardware sectors (2033 MB)
sd 12:0:0:0: [sdb] Write Protect is off
sd 12:0:0:0: [sdb] Mode Sense: 03 00 00 00
sd 12:0:0:0: [sdb] Assuming drive cache: write through
 sdb: sdb1
end_request: I/O error, dev sdb, sector 3970041
sd 12:0:0:0: [sdb] 3970048 512-byte hardware sectors (2033 MB)
sd 12:0:0:0: [sdb] Write Protect is off
sd 12:0:0:0: [sdb] Mode Sense: 03 00 00 00
sd 12:0:0:0: [sdb] Assuming drive cache: write through
sd 12:0:0:0: [sdb] 3970048 512-byte hardware sectors (2033 MB)
sd 12:0:0:0: [sdb] Write Protect is off
sd 12:0:0:0: [sdb] Mode Sense: 03 00 00 00
sd 12:0:0:0: [sdb] Assuming drive cache: write through
 sdb: sdb1
end_request: I/O error, dev sdb, sector 3970041
...

And this is what I see in /var/log/messages (observe the times):

Jan 26 18:31:42 Orion kernel: usb 1-7: new high speed USB device using ehci_hcd 
and address 13
Jan 26 18:31:42 Orion kernel: usb 1-7: configuration #1 chosen from 1 choice
Jan 26 18:31:42 Orion kernel: scsi14 : SCSI emulation for USB Mass Storage 
devices
Jan 26 18:31:47 Orion kernel: scsi 14:0:0:0: Direct-Access     USB      Storage 
Device        PQ: 0 ANSI: 2
Jan 26 18:31:47 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:31:47 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:31:47 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:31:47 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:31:47 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:31:47 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:31:47 Orion kernel:  sdb: sdb1
Jan 26 18:31:47 Orion kernel: sd 14:0:0:0: [sdb] Attached SCSI removable disk
Jan 26 18:31:47 Orion kernel: sd 14:0:0:0: Attached scsi generic sg3 type 0
Jan 26 18:31:48 Orion kernel: end_request: I/O error, dev sdb, sector 3970041
Jan 26 18:31:48 Orion kernel: printk: 251 messages suppressed.
Jan 26 18:31:48 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969792
Jan 26 18:31:48 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969793
Jan 26 18:31:48 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969794
Jan 26 18:31:48 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969795
Jan 26 18:31:48 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969796
Jan 26 18:31:48 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969797
Jan 26 18:31:48 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969798
Jan 26 18:31:48 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969792
Jan 26 18:31:48 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969793
Jan 26 18:31:48 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969794
Jan 26 18:31:48 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:31:48 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:31:48 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:31:48 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:31:48 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:31:48 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:31:48 Orion kernel:  sdb: sdb1
Jan 26 18:31:49 Orion kernel: end_request: I/O error, dev sdb, sector 3970041
Jan 26 18:31:49 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:31:49 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:31:49 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:03 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:03 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:03 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:03 Orion kernel:  sdb: sdb1
Jan 26 18:32:04 Orion kernel: end_request: I/O error, dev sdb, sector 3970041
Jan 26 18:32:04 Orion kernel: printk: 164 messages suppressed.
Jan 26 18:32:04 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969792
Jan 26 18:32:04 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969793
Jan 26 18:32:04 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969794
Jan 26 18:32:04 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:04 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:04 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:04 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:04 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:04 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:04 Orion kernel:  sdb: sdb1
Jan 26 18:32:05 Orion kernel: end_request: I/O error, dev sdb, sector 3970041
Jan 26 18:32:05 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:05 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:05 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:19 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:19 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:19 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:19 Orion kernel:  sdb: sdb1
Jan 26 18:32:20 Orion kernel: end_request: I/O error, dev sdb, sector 3970041
Jan 26 18:32:20 Orion kernel: printk: 171 messages suppressed.
Jan 26 18:32:20 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969792
Jan 26 18:32:20 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969793
Jan 26 18:32:20 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969794
Jan 26 18:32:20 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:20 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:20 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:20 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:20 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:20 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:20 Orion kernel:  sdb: sdb1
Jan 26 18:32:21 Orion kernel: end_request: I/O error, dev sdb, sector 3970041
Jan 26 18:32:21 Orion kernel: end_request: I/O error, dev sdb, sector 281
Jan 26 18:32:21 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:21 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:21 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:21 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:21 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:21 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:21 Orion kernel:  sdb: sdb1
Jan 26 18:32:22 Orion kernel: end_request: I/O error, dev sdb, sector 3970041
Jan 26 18:32:22 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:22 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:22 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:22 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:22 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:22 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:22 Orion kernel:  sdb: sdb1
Jan 26 18:32:23 Orion kernel: end_request: I/O error, dev sdb, sector 3970041
Jan 26 18:32:23 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:23 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:23 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:23 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:23 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:23 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:23 Orion kernel:  sdb: sdb1
Jan 26 18:32:24 Orion kernel: end_request: I/O error, dev sdb, sector 3970041
Jan 26 18:32:24 Orion kernel: printk: 633 messages suppressed.
Jan 26 18:32:24 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969792
Jan 26 18:32:24 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:24 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:24 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:35 Orion kernel: sd 14:0:0:0: [sdb] 3970048 512-byte hardware 
sectors (2033 MB)
Jan 26 18:32:35 Orion kernel: sd 14:0:0:0: [sdb] Write Protect is off
Jan 26 18:32:35 Orion kernel: sd 14:0:0:0: [sdb] Assuming drive cache: write 
through
Jan 26 18:32:35 Orion kernel:  sdb: sdb1
Jan 26 18:32:36 Orion kernel: end_request: I/O error, dev sdb, sector 3970041
Jan 26 18:32:36 Orion kernel: printk: 86 messages suppressed.
Jan 26 18:32:36 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969792
Jan 26 18:32:36 Orion kernel: Buffer I/O error on device sdb1, logical block 
3969793


After this, the device is ejected (turn off the light, and 'mount /dev/sdb1' 
gives: mount: special device /dev/sdb1 does not exist

Expected results:
Card mounted.

Additional info:
- I tried with 4 kernels, in particular with the original one for Fedora 8 
which worked until 2 weeks ago, with the same results.
- If I try to force mount issuing the command 'mount /dev/sdb1' several times, 
sometimes it is mounted. When umounting it the problem returns until it is 
ejected.
- When mounting the card with a camera instead of the card reader, it works 
fine.
- Everything works fine in windows...
Comment 1 Luis A. Florit 2008-02-11 18:57:06 EST

*** This bug has been marked as a duplicate of 188544 ***

Note You need to log in before you can comment on or make changes to this bug.