Bug 430572 - RHEL5.2-Server-20080117.1 fails to boot post-install - grubby segfaults
RHEL5.2-Server-20080117.1 fails to boot post-install - grubby segfaults
Status: CLOSED DUPLICATE of bug 253116
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.2
powerpc Linux
high Severity high
: beta
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-28 15:40 EST by James Laska
Modified: 2013-09-02 02:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-01 16:23:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda-logs.tar.bz2 (install.log, anaconda.log, syslog) (29.91 KB, application/octet-stream)
2008-01-28 17:18 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2008-01-28 15:40:20 EST
Description of problem:

The install completes but panics on boot (as indicated in RHTS log
http://rhts.lab.boston.redhat.com/cgi-bin/rhts/test_log.cgi?id=1781773).

Waiting for driver initialization.
Scanning and configuring dmraid supported devices
Scanning logical volumes
  Reading all physical volumes.  This may take a while...
  Found volume group "VolGroup00" using metadata type lvm2
Activating logical volumes
  /proc/misc: No entry for device-mapper found
  Is device-mapper driver missing from kernel?
  Failure to communicate with kernel device-mapper driver.
  0 Kernel panic - not syncing: Attempted to kill init!
logical volume(s ) in volume grou

Version-Release number of selected component (if applicable):

RHEL5.2-Server-20080117.1
 * kernel-2.6.18.62.el5.ppc64
 * anaconda-11.1.2.87.1.ppc
 * mkinitrd-5.1.19.6.19.ppc64


How reproducible:
100%

Steps to Reproduce:
1. Install using default lvm layout
  
Actual results:

Panic's on boot 

Expected results:


Additional info:

$ diff -y -W50 r5u1-initrd-cpio-it r5u2-initrd-cpio-it

lib                                             lib
lib/dm-mirror.ko                              <
lib/dm-mod.ko                                 <
lib/dm-snapshot.ko                            <
lib/dm-zero.ko                                <
lib/ehci-hcd.ko                                 lib/ehci-hcd.ko


Running /sbin/new-kernel-pkg by hand shows that grubby is segfaulting 

++ echo -/boot/initrd-2.6.18-62.el5.img
++ sed 's/\/boot.*img//'
+ initrdnum=-
+ '[' - = - ']'
+ initrdnum=
+ /sbin/grubby --add-kernel=/boot/vmlinuz-2.6.18-62.el5 --initrd
/boot/initrd-2.6.18-62.el5.img --copy-default --make-default --title
2.6.18-62.el5 '--args=root=/dev/VolGroup00/LogVol00 '
--remove-kernel=TITLE=2.6.18-62.el5 --yaboot
/sbin/new-kernel-pkg: line 90:  1930 Segmentation fault      (core dumped)
$grubby --add-kernel=$bootPrefix/$kernelName-$version $INITRD --copy-default
$makedefault --title "$version$initrdnum"
${mbkernel:+--add-multiboot="$mbkernel"} ${mbargs:+--mbargs="$mbargs"}
--args="root=$rootdevice $kernargs" --remove-kernel="TITLE=$version$initrdnum"
--$liloFlag
+ '[' -n yes ']'
+ '[' -n '' ']'
+ '[' '!' -x /sbin/ybin ']'

Attempting to use gdb on the resulting core file ...
Comment 1 James Laska 2008-01-28 16:16:50 EST
I can't seem to get a useful backtrace :(

# rpm -q glibc glibc-debuginfo mkinitrd mkinitrd-debuginfo
glibc-2.5-18.ppc
glibc-2.5-18.ppc64
glibc-debuginfo-2.5-18.ppc64
mkinitrd-5.1.19.6-19.ppc64
mkinitrd-5.1.19.6-19.ppc
mkinitrd-debuginfo-5.1.19.6-19.ppc
mkinitrd-debuginfo-5.1.19.6-19.ppc64

$ gdb --core=/tmp/core-mkinitrd
...
This GDB was configured as "ppc64-redhat-linux-gnu".
(no debugging symbols found)
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `gdb '.
Program terminated with signal 11, Segmentation fault.
#0  0x00000400000229e4 in ?? ()
(gdb) bt
#0  0x00000400000229e4 in ?? ()
#1  0x0000040000005d88 in ?? ()
#2  0x0000000000000000 in ?? ()
Comment 3 RHEL Product and Program Management 2008-01-28 16:45:25 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 James Laska 2008-01-28 17:18:56 EST
Created attachment 293212 [details]
anaconda-logs.tar.bz2 (install.log, anaconda.log, syslog)

$ tar -jtvf Desktop/RHEL5.2-Server-20080117.1-ppc.tar.bz2 
-rw------- jlaska/jlaska 287325 2008-01-28 17:16 anaconda.log
-rw------- jlaska/jlaska  11892 2008-01-28 17:16 anaconda.syslog
-rw-r--r-- jlaska/jlaska  17320 2008-01-28 17:16 install.log
Comment 7 Peter Jones 2008-02-01 16:23:17 EST
This is due to /lib64/ld64.so segfaulting.

*** This bug has been marked as a duplicate of 253116 ***

Note You need to log in before you can comment on or make changes to this bug.