Bug 43090 - Failed cbq init if source port specified
Summary: Failed cbq init if source port specified
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: shapecfg   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
: 43960 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-31 19:22 UTC by Need Real Name
Modified: 2008-08-01 16:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-17 19:06:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-05-31 19:22:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
When I specify source port in config file and try 'cbq start' , I get 
error message.

How reproducible:
Always

Steps to Reproduce:
1. Create config file /etc/sysconfig/cbq/cbq-0128.foo:
===cut===
DEVICE=eth0,10Mbit,1Mbit
RATE=128Kbit
WEIGHT=10Kbit
PRIO=5
RULE=192.168.1.1:20,
===cut===
2. su root
3. /sbin/cbq start


Actual Results:  I get error in /sbin/cbq script:
===cut===
What is "ff"?
Usage: ... u32 [ match SELECTOR ... ] [ link HTID ] [ classid CLASSID ]
               [ police POLICE_SPEC ] [ offset OFFSET_SPEC ]
               [ ht HTID ] [ hashkey HASHKEY_SPEC ]
               [ sample SAMPLE ]
or         u32 divisor DIVISOR

Where: SELECTOR := SAMPLE SAMPLE ...
       SAMPLE := { ip | ip6 | udp | tcp | icmp | u{32|16|8} } SAMPLE_ARGS
       FILTERID := X:Y:Z
===cut===


Additional info:

I found, that a reason of this is a unexpected EOF in /sbin/cbq script in 
following lines: 183, 205, 228.

Comment 1 Mike A. Harris 2001-07-17 19:06:37 UTC
*** Bug 43960 has been marked as a duplicate of this bug. ***

Comment 2 Mike A. Harris 2001-07-17 19:08:37 UTC
Resolved, rawhide.  Release: shapecfg-2.2.12-7

Will appear in rawhide soon.


Note You need to log in before you can comment on or make changes to this bug.