Bug 43960 - Problem with dest Port
Summary: Problem with dest Port
Status: CLOSED DUPLICATE of bug 43090
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: shapecfg   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-08 13:41 UTC by Ivan Martinez
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-08 13:42:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff from my changes to original file (632 bytes, patch)
2001-06-08 13:42 UTC, Ivan Martinez
no flags Details | Diff

Description Ivan Martinez 2001-06-08 13:41:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-7.0.1 i586)

Description of problem:
In some cases the tc filter are made with source instead of destination.

How reproducible:
Always

Steps to Reproduce:
1.
Create a cbq file with a rule like :
RULE=,:25
2. cbq start
3. tc filter show dev ethX
	

Actual Results:  The filter are applied to the source port not dest port.

Expected Results:  Filter aplied to dest port.

Additional info:

I have changed the /sbin/cbq to correct this in 2 lines, because are also a
problem with ip address.
The changes are 
line : 208  "match ip src" must be "match ip dst"
line : 212  "match ip sport" must be "match ip dport"

Comment 1 Ivan Martinez 2001-06-08 13:42:28 UTC
Created attachment 20613 [details]
diff from my changes to original file

Comment 2 Mike A. Harris 2001-07-17 19:06:42 UTC

*** This bug has been marked as a duplicate of 43090 ***


Note You need to log in before you can comment on or make changes to this bug.