Bug 430998 - 500 Internal error on po submission in transifex
500 Internal error on po submission in transifex
Status: CLOSED DUPLICATE of bug 303991
Product: Fedora Localization
Classification: Fedora
Component: Website (Show other bugs)
unspecified
All Linux
urgent Severity high
: ---
: ---
Assigned To: Dimitris Glezos
A S Alam
:
: 430271 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-30 18:57 EST by Gianluca Busiello
Modified: 2013-07-02 20:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-06 18:19:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file to be uploaded on transifex (8.82 KB, text/x-gettext-translation)
2008-01-30 18:57 EST, Gianluca Busiello
no flags Details

  None (edit)
Description Gianluca Busiello 2008-01-30 18:57:10 EST
Description of problem:
Server error trying to upload a modified po file on fedora transifex.
A similar problem is already reported and closed, but that fix doesn't apply
because it solves an error when the user commits with a username containing
unicode characters. My fedora username is "gianluca".


Version-Release number of selected component (if applicable):


How reproducible:
Uploading a modified version of a translated file.

Steps to Reproduce:
1. download
http://translate.fedoraproject.org/POT/firstboot.master/firstboot.master.it.po
2. open it with a translation application
3.  save it in utf-8 charset
4. upload the saved file, overwriting the po/it_po file
  
Actual results:
500 Internal error The server encountered an unexpected condition which
prevented it from fulfilling the request.

Expected results:
the preview of the uploaded po file

Additional info: 
Looking at the header of the po file, before modifications, the field charset is
set to ISO-8859-1, while my file (edited with kbabel) is UTF-8.
Comment 1 Gianluca Busiello 2008-01-30 18:57:10 EST
Created attachment 293523 [details]
file to be uploaded on transifex
Comment 2 Piotr Drąg 2008-01-30 19:02:19 EST
Same situation with Polish files, which all are UTF-8.
Comment 3 Miloš Komarčević 2008-01-30 19:07:02 EST
Been seeing the same with im-chooser (Serbian, also utf8) for the past couple of
days, even though some people seem to have managed to commit something yesterday?
Comment 4 Piotr Drąg 2008-02-01 19:41:39 EST
*** Bug 430271 has been marked as a duplicate of this bug. ***
Comment 5 Piotr Drąg 2008-02-05 06:50:15 EST
Ping.

I couldn't submit any translations because of this. :(
Comment 6 Dimitris Glezos 2008-02-06 18:19:04 EST
I have been able to reproduce this and, from what I understand, it's a DUPE of
#303991. Continuing discussion there.

*** This bug has been marked as a duplicate of 303991 ***
Comment 7 Piotr Drąg 2009-07-03 16:07:25 EDT
Mass change of component from Transifex to Website, since all our websites are handled by Transifex now.

Note You need to log in before you can comment on or make changes to this bug.