Bug 431094 - ipa-server-install no longer creates named configuration when asked to.
ipa-server-install no longer creates named configuration when asked to.
Status: CLOSED CANTFIX
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Simo Sorce
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-31 13:36 EST by Michael Gregg
Modified: 2015-01-04 18:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 18:14:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Gregg 2008-01-31 13:36:52 EST
Description of problem:
Invoking ipa-server-install doesn't create zone files in /var/named anymore, 
nor does it create/change /etc/named.conf

Version-Release number of selected component (if applicable):
build from 1-31-08:
http://apoc.dsdev.sjc.redhat.com/tet/results/FC7/i386/2008-01-31_03_01-build/
ipa.repo

How reproducible:
install the server with the unattended and setup-bins options set.

Steps to Reproduce:
1.install ipa-server rpms on a fresh system
2./usr/sbin/ipa-server-install -U --
hostname=ipaqavm.dsqa.sjc2.redhat.com -r DSQA.SJC2.REDHAT.COM -p pw -P pw -a pw 
--setup-bind -u admin -d
  
Actual results:
/etc/named.conf doesn't exist
no zone files in /var/named/chroot

Expected results:
named configuration file creation

Additional:
The build from 1-29-08 worked well.
Comment 1 Rob Crittenden 2008-01-31 14:52:45 EST
Doesn't this step happen AFTER the web UI is installed? 

I think that this is a result of bug 431089. I can't reproduce this after fixing
the UI bug. 

Can you test with patch from the 431089?
Comment 2 Rob Crittenden 2008-01-31 14:55:36 EST
re-assigned to Simo in case it really is a bug.
Comment 3 Simo Sorce 2008-01-31 18:14:07 EST
The logs clearly show that the install scripts bailed out before the named
configuration step was performed, so fixing the webui step fix this too.

Re-open if this still persist after the webui is fixed, but its unlikely.
Comment 4 Michael Gregg 2008-02-01 20:11:55 EST
 
I can't really verify this bug, but last nights build didn't seem to have this
problem. 


Note You need to log in before you can comment on or make changes to this bug.