Bug 431124 - resizing certain ntfs partitions leads to unhandled exception
resizing certain ntfs partitions leads to unhandled exception
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
NeedsRetesting
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-01-31 15:50 EST by Jesse Keating
Modified: 2013-01-09 21:44 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 16:09:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-01-31 15:50:45 EST
RuntimeError: Resize of /dev/sda3 failed

From tty5 I get:

ERROR: The fragmentation type, you have, isn't supported yet.  Rerun ntfsresize
with the -i option to estimate the smallest shrunken volume size supported.

This was from a factory installed Vista from Acer.  THere was a C and a D
partition, the D (sda3) is what I was trying to resize down to 2G (it had no
data on it).
Comment 1 Jesse Keating 2008-01-31 16:07:55 EST
As discussed in person, this was actually because I tried to resize to a size
that was not usable.  This was due to the disk being fragmented in a way that
ntfsresize couldn't defragment.  The -i was just for getting info about what
size you could go to.  Perhaps anaconda should use -i to see what it can
actually resize to instead of assuming that the disk usage space is what could
be resized to.
Comment 2 Jeremy Katz 2008-01-31 16:15:33 EST
Well, we're using -i to get what you can resize to... it just happens that
there's more things ntfsresize -i outputs that are relevant and no nice way to
get them other than screenscraping :-/
Comment 3 Jeremy Katz 2008-03-05 14:03:11 EST
Added what should fix this (using the ntfsresize -m option jesse added) to git.
 I don't have an NTFS box handy today to test it though
Comment 4 Jesse Keating 2008-04-01 17:12:53 EDT
I don't have that machine any more either.
Comment 5 Jon Stanley 2008-04-18 20:01:21 EDT
I'll plead to f-test-list on this one
Comment 6 bryanjh 2008-04-18 21:09:11 EDT
Per Jon's request I just tested this on the kde preview live cd. I do not get
the exact same error, but ntfs resizing fails nonetheless. I attempt to shrink
my ntfs partition from 100GB to 90GB and I get this error.

Could not allocate requested partitions:

Partitioning failed: Unsatisfied partition request
New Part Request -- mountpoint: None uniqueID: 5
  type: physical volume (LVM)  format: 1
  device: None drive: [u'sdb']  primary: None
  size: 0  grow: 1  maxsize: None
  start: None  end: None  migrate: None    fslabel: None  origfstype: None
  options: 'None'
  fsprofile: None  encryption: None.

Then I click okay and I get a second error:

The following errors occurred with your partitioning:

You have not defined a root partition (/), which is required for
installation of Fedora to continue.

This can happen if there is not enough space on your hard drive(s) for
the installation.

Press 'OK' to choose a different partitioning option.

There are a couple warnings on tty3 as well:
WARNING: Unable to discover minimumsize of filesystem on sda1
WARNING: step complete does not exist

This is happening on my Toshiba a105-s4284 laptop. Let me know if additional
information is required.
Comment 7 Jon Stanley 2008-04-18 22:02:16 EDT
changing back to assigned so this doesn't get lost
Comment 8 bryanjh 2008-04-19 16:40:44 EDT
So I downloaded the DVD install iso and attempted to do a resize/autopartition
and I received similar results. I tried to resize using custom option and it
failed as well, but with different error messages.

"Running ...['ntfsresice', '-v', '-s', '85145M', '/dev/sda1'] ntfsresize v2.0.0
(libntfs 10:0:0)" with 'Exit Installer' as the only option. I looked on tty4 and
saw four segfaults roughly of this form <6> ntfsresize [1717]: seqfault at 8
ip0804ebd0 sp bf6e010 error 4 in ntfs resize [8048000 + a000]. 

I could use a gparted livecd to resize, but I'm not in a hurry and I am willing
to leave this system unchanged in the meantime for future testing.
Comment 9 Jeremy Katz 2008-04-20 21:08:10 EDT
(In reply to comment #8)
> "Running ...['ntfsresice', '-v', '-s', '85145M', '/dev/sda1'] ntfsresize v2.0.0
> (libntfs 10:0:0)" with 'Exit Installer' as the only option. I looked on tty4 and
> saw four segfaults roughly of this form <6> ntfsresize [1717]: seqfault at 8
> ip0804ebd0 sp bf6e010 error 4 in ntfs resize [8048000 + a000]. 

Is this with the PR or the beta?  If the latter, then you're hitting bug 438822
Comment 10 bryanjh 2008-04-20 21:31:48 EDT
PR
Comment 11 Jeremy Katz 2008-04-22 14:44:20 EDT
It's at least not throwing an exception.  The segfault is likely another bug in
ntfsprogs :(  Can you open something against it and try to get a backtrace with
gdb?  (Running it by hand from the livecd with the appropriate options after
installing gdb shouldn't be bad to do)
Comment 12 bryanjh 2008-04-25 17:52:26 EDT
I ended up formatting my windows partition so I am currently unable to do this.
Perhaps over the weekend I will install windows again so I can get the backtrace.
Comment 13 bryanjh 2008-04-26 04:59:30 EDT
I tried to do this just now and I am unable to get the necessary debugging
info.

Could not find debuginfo for main pkg: ntfsprogs-2.0.0-6.fc9.i386
Could not find debuginfo pkg for dependency package ntfsprogs-2.0.0-6.fc9.i386
Could not find debuginfo pkg for dependency package e2fsprogs-

It is worth noting that running ntfsresize -i /dev/sda1/ results in an
immediate segmentation fault.
Comment 14 Jon Stanley 2008-04-26 16:33:53 EDT
First of all, the / on the end is not necessary (in fact, completely wrong), and
may be confusing ntfsresize (though it should error out rather than
segfaulting).     Secondly, try to do this to run it under gdb with symbols:

yum install yum-utils
debuginfo-install ntfsprogs

Then you'll have the symbols it's complaining about.  Once you do that, and
return to the gdb prompt after the segfault, type 'thread apply all bt full' and
attach the resulting output here. 
Comment 15 bryanjh 2008-04-26 20:52:09 EDT
Those errors were output from debuginfo-install. I updated ntfsprogs and then I
was able to install the debug packages. Updating the package stopped ntfsresize
from segfaulting, but install still refuses to resize my ntfs partition.
Comment 16 Jeremy Katz 2008-04-28 22:42:57 EDT
The ntfsresize segv in F9Preview is bug 443988 (which spot fixed the end of the
week)
Comment 17 Will Woods 2008-05-09 17:33:05 EDT
So, the segfault and unhandled exception are fixed? If so, this bug should be
closed.

ntfsresize being unable to resize certain partitions is a separate problem,
which would need its own bug report.
Comment 18 Bug Zapper 2008-05-14 00:57:16 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 19 Jonas Nyman 2008-05-14 14:18:53 EDT
I had a similar experience, although I have no idea if it's the same bug.

I was installing FC9 x86_64 on a new HP pavilion tx1000.

I wanted to shrink the preinstalled vista partition from some 150 Gb to around
100. It was a fresh install so there was plenty of space.

It first seemed to work, I got a progress bar. But then I got an error message
saying something like "resizing of /dev/sda3 failed. 1 sector mismatch? Run
chkdsk /f and reboot twice. The /f parameter is important. Please file a
bugreport to bugzilla... and then lots and lots of debug info..."

I got two options, either to start a debug console of exit the installation. 
I choose to exit and was left with a black screen with a wrist watch mouse cursor. 
Comment 20 Szabolcs Szakacsits 2008-05-14 21:31:15 EDT
NTFS support on Linux is self-contained (like ext3, XFS, JFS, FAT, etc) which
means, among others, that testing doesn't need either NTFS disk, or NTFS box
because mkntfs can be used on a image file, block or loop device. Examples:
http://ntfs-3g.org/quality.html#howtotest

Note You need to log in before you can comment on or make changes to this bug.