Bug 431132 - hdiso installs fail due to "missing repodata" - isos not mounted
hdiso installs fail due to "missing repodata" - isos not mounted
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 433269 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-01-31 16:50 EST by Will Woods
Modified: 2008-02-25 15:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 16:16:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-hdiso.log (20.10 KB, text/plain)
2008-01-31 16:50 EST, Will Woods
no flags Details

  None (edit)
Description Will Woods 2008-01-31 16:50:09 EST
I attempted a hdiso install of Fedora 9 Alpha for i386. Booted the machine from
the Rescue image. The CD isos were on a (vfat-formatted) USB drive. 

Told loader to fetch images from sdb1, in the directory 9-Alpha/Fedora/i386/iso
and it happily loaded stage2 and continued into the GUI. anaconda.log has the
following message:

19:49:11 INFO    : Found hd stage2, copying /tmp/loopimage///images/stage2.img
in RAM as stage2

So the installer *did* find sdb1 and mounted disc1 just fine.

I did the normal steps - choose timezone, partition drive, etc. When it tried to
get repo metadata, the installer popped up a message like:

"Unable to read package metadata. ... Cannot retrieve repository metadata
(repomd.xml) for repository: anaconda-FedoraBase-$(datestamp).i386. Please
verify its path and try again. [Abort]"

Checked tty2 - /dev/sdb1 was not mounted, and neither were any of the ISO images.

I'm attaching the anaconda.log from that system.
Comment 1 Will Woods 2008-01-31 16:50:09 EST
Created attachment 293654 [details]
anaconda-hdiso.log
Comment 2 Chris Lumens 2008-02-25 15:45:59 EST
*** Bug 433269 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.