Bug 431327 - Unable to build Xen because latex fails in buildroot
Unable to build Xen because latex fails in buildroot
Status: CLOSED DUPLICATE of bug 431516
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-02 16:22 EST by Daniel Berrange
Modified: 2013-07-02 19:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-05 11:57:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2008-02-02 16:22:43 EST
Description of problem:
Xen packages which BuildRequires: tetex-latex, fail in mock

http://koji.fedoraproject.org/koji/taskinfo?taskID=390305

Build the latex command is aborting

mock-chroot> cd builddir/build/BUILD/xen-3.2.0/           
mock-chroot> cd docs/
mock-chroot> latex src/user.tex                          
This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6)
 %&-line parsing enabled.
kpathsea: Running mktexfmt latex.fmt
I can't find the format file `latex.fmt'!

This is critical because it makes it impossible to do new builds & thus is
blocking all Xen userspace development in rawhide.

Version-Release number of selected component (if applicable):
# rpm -qa | grep texlive | sort
texlive-2007-16.fc9.x86_64
texlive-dvips-2007-16.fc9.x86_64
texlive-latex-2007-16.fc9.x86_64
texlive-texmf-2007-10.fc9.noarch
texlive-texmf-dvips-2007-10.fc9.noarch
texlive-texmf-errata-2007-1.fc9.noarch
texlive-texmf-errata-dvips-2007-1.fc9.noarch
texlive-texmf-errata-fonts-2007-1.fc9.noarch
texlive-texmf-errata-latex-2007-1.fc9.noarch
texlive-texmf-fonts-2007-10.fc9.noarch
texlive-texmf-latex-2007-10.fc9.noarch


How reproducible:
Always

Steps to Reproduce:
1. cvs co xen
2. cd xen/devel
3. make srpm
4. mock rebuild -r fedora-devel-x86_64 `pwd`/xen-3.2.0-4.fc9.src.rpm
  
Actual results:
Fails because latex fails

Expected results:
Build succeeeds

Additional info:
This only started happening since switch to texlive
Comment 1 Daniel Berrange 2008-02-02 16:28:01 EST
If I manually run this:

/usr/bin/texconfig-sys rehash 

within the build root, then I can complete the Xen build. This ought to be run
by the %postinstall script of texlive, but something must be breaking it.
Comment 2 Daniel Berrange 2008-02-02 17:13:42 EST
Further to my original comment, the problem actually seems to have happened more
recently - post the texlive introduction.

I managed to do a successful build on Jan 21st, with texlive-2007-13.fc9 and
texlive-texmf-8.fc9
Comment 3 Miroslav Lichvar 2008-02-05 11:57:36 EST

*** This bug has been marked as a duplicate of 431516 ***

Note You need to log in before you can comment on or make changes to this bug.