Bug 431516 - thousands of processes spawned
thousands of processes spawned
Status: CLOSED DUPLICATE of bug 437008
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
rawhide
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
: Reopened
: 431238 431327 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-05 03:02 EST by Dennis Gilmore
Modified: 2013-07-02 19:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 14:38:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2008-02-05 03:02:29 EST
Description of problem:
on the buildsystem thousands of pdftex processes get spawned.  for example  see
http://ausil.fedorapeople.org/sigh  it is a 81MB file that is the output of ps
-axf also see http://koji.fedoraproject.org/koji/buildinfo?buildID=34157  all
arches but i386 completed fine same for
http://koji.fedoraproject.org/koji/taskinfo?taskID=395141

Version-Release number of selected component (if applicable):
  

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kevin Kofler 2008-02-05 04:51:55 EST
For those who don't want to download the 81 MB ps listing, here's the relevant 
part:
 2202 ?        S      0:00  |                           \_ 
etex -ini -jobname=xmltex -progname=xmltex &latex xmltex.ini
 2424 ?        S      0:00  |                               
\_ /bin/sh /usr/bin/mktexfmt xmltex.fmt
 2584 ?        S      0:00  |                                   
\_ /bin/sh /usr/bin/mktexfmt xmltex.fmt
 2585 ?        S      0:00  |                                       \_ 
pdftex -ini -jobname=xmltex -progname=xmltex &latex xmltex.ini
 2807 ?        S      0:00  |                                           
\_ /bin/sh /usr/bin/mktexfmt xmltex.fmt
and there the infinite loop starts, always 2 mktexfmt processes and 1 pdftex 
process, they're calling each other in an endless loop.
Comment 2 Miroslav Lichvar 2008-02-05 11:56:04 EST
A dependency loop caused texlive-latex to be installed before
texlive-texmf-latex, so latex.fmt wasn't created.

texlive-texmf-2007-11.fc9 should have this fixed.
Comment 3 Miroslav Lichvar 2008-02-05 11:57:37 EST
*** Bug 431327 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Lichvar 2008-02-05 12:11:24 EST
*** Bug 431238 has been marked as a duplicate of this bug. ***
Comment 5 Patrice Dumas 2008-02-05 12:21:09 EST
I think that these scriptlet issues should be fixed once for 
all with a proper understanding of what order should be best
and how to implement it.
Comment 6 Jindrich Novy 2008-02-21 09:37:23 EST
This should be resolved now in rawhide. Please reopen if you see it again.
Comment 7 Patrice Dumas 2008-02-25 17:42:19 EST
The texinfo-tex requires can go since it also brings in texinfo,
so this is a bit too much. Howver the tex-preview makes sense.

Why not add the 
Requires(post): %{_bindir}/texconfig-sys /sbin/install-info

to ensure the right ordering and drop the conditionals?
And remove the postscripts from the texlive and put them 
in the texlive-texmf such that the ini files and map files
are there when the fmtutil and updmap scriptlets are called?
Comment 8 Patrice Dumas 2008-02-25 17:43:20 EST
(In reply to comment #2)
> A dependency loop caused texlive-latex to be installed before
> texlive-texmf-latex, so latex.fmt wasn't created.
> 
> texlive-texmf-2007-11.fc9 should have this fixed.

It is actually logical to have texlive-latex be installed before
texlive-texmf-latex. But the script should be called after 
texlive-texmf-latex installation, in my opinion.
Comment 9 Jindrich Novy 2008-03-12 14:38:19 EDT
It seems to be fixed by patch in bug #437003. Closing as duplicate.

*** This bug has been marked as a duplicate of 437008 ***

Note You need to log in before you can comment on or make changes to this bug.