Bug 431357 - Printer setup with HP JetDirect hourglass forever
Printer setup with HP JetDirect hourglass forever
Status: CLOSED DUPLICATE of bug 431252
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-03 10:10 EST by Need Real Name
Modified: 2008-02-04 13:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-04 13:28:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2008-02-03 10:10:29 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Select System > Administration > Printing on Gnome menu
2. Click New Printer
3. Click AppSocket/HP JetDirect
4. Enter Print Server IP address, for example, 192.168.0.110
5. Leave Port number at default 9100
6. Click Forward

Actual results: The hourglass spins forever.

Expected results: It should advance to printer model selection dialog.

Additional info:
The exact same procedure with another Linux distro immediately advances to
printer model selection dialog (correct).
I have hplip and hpijs packages installed.  The print server is IOGear USB Print
Server.
Comment 1 Tim Waugh 2008-02-03 15:28:01 EST
What does 'rpm -q system-config-printer' say?
Comment 2 mdeiss 2008-02-04 12:47:41 EST
I have the same problem on two machines:

rpm -q system-config-printer returns
system-config-printer-0.7.74.10-2.fc8

The out-of-the-box FC8-DVD-ISO installed version seems to work OK as I've
installed two printers OK.  But, after the latest FC8 updates to various
programs, the printer-config program gets broken.

When running in a terminal window, I see the following:
fetchDevices
queryDevices
Lock acquired for devices thread
Devices thread started
Connecting (devices)
Fetching devices
Closing connection (devices)
Releasing devices lock
Acquiring devices lock
Got devices
queryPPDs
Lock acquired for PPDs thread
PPDs thread started
Connecting (PPDs)
Fetching PPDs
Closing connection (PPDs)
Releasing PPDs lock
fetchPPDs
Acquiring PPDs lock
Got PPDs
Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 2263,
in on_btnNPForward_clicked
    self.nextNPTab()
  File "/usr/share/system-config-printer/system-config-printer.py", line 2298,
in nextNPTab
    host = self.getNetworkPrinterMakeModel(self.device)
  File "/usr/share/system-config-printer/system-config-printer.py", line 2558,
in getNetworkPrinterMakeModel
    debugprint (host + ": " + cmd)
NameError: global name 'debugprint' is not defined


Comment 3 Tim Waugh 2008-02-04 13:28:26 EST

*** This bug has been marked as a duplicate of 431252 ***

Note You need to log in before you can comment on or make changes to this bug.