Bug 431252 - Fails when adding an ipp printer
Summary: Fails when adding an ipp printer
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer   
(Show other bugs)
Version: 8
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 431357 431837 432422 (view as bug list)
Depends On:
Blocks: F8Target
TreeView+ depends on / blocked
 
Reported: 2008-02-01 19:46 UTC by Sergio Pascual
Modified: 2008-02-13 04:51 UTC (History)
3 users (show)

Fixed In Version: 0.7.74.10-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 04:47:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sergio Pascual 2008-02-01 19:46:57 UTC
Description of problem:
system-confi-printer fail when adding an ipp printer

Version-Release number of selected component (if applicable):
system-config-printer-0.7.74.10-2.fc8

How reproducible:
Always

Steps to Reproduce:
1. Add a new printer
2. Select ipp
3. Fill the blanks
4. Press next

  
Actual results:
Nothing happens

Expected results:
In the next screen we select the driver

Additional info:
When running the program in a terminal and I press next, this ouput appears
Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 2263,
in on_btnNPForward_clicked
    self.nextNPTab()
  File "/usr/share/system-config-printer/system-config-printer.py", line 2298,
in nextNPTab
    host = self.getNetworkPrinterMakeModel(self.device)
  File "/usr/share/system-config-printer/system-config-printer.py", line 2558,
in getNetworkPrinterMakeModel
    debugprint (host + ": " + cmd)
NameError: global name 'debugprint' is not defined

Comment 1 Tim Waugh 2008-02-02 11:24:01 UTC
Oops, this change was back-ported from trunk where 'debugprint' is defined. 
I've added the debugprint() function to the 0.7.74.x branch and will provide an
updated package shortly.

Comment 2 Fedora Update System 2008-02-02 11:26:21 UTC
system-config-printer-0.7.74.10-3.fc7 has been submitted as an update for Fedora 7

Comment 3 Tim Waugh 2008-02-02 11:28:09 UTC
(Note: there will be two update notifications, one for Fedora 7 and the other
for Fedora 8.  Please wait for the Fedora 8 one.)

Comment 4 Fedora Update System 2008-02-04 18:27:45 UTC
system-config-printer-0.7.74.10-3.fc8 has been submitted as an update for Fedora 8

Comment 5 Tim Waugh 2008-02-04 18:28:28 UTC
*** Bug 431357 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2008-02-07 03:35:47 UTC
system-config-printer-0.7.74.10-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1414

Comment 7 Tim Waugh 2008-02-07 09:42:47 UTC
*** Bug 431837 has been marked as a duplicate of this bug. ***

Comment 8 Tim Waugh 2008-02-11 23:11:19 UTC
*** Bug 432422 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2008-02-13 04:47:57 UTC
system-config-printer-0.7.74.10-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2008-02-13 04:51:44 UTC
system-config-printer-0.7.74.10-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.