Bug 4315 - gtk errors during Linuxconf
gtk errors during Linuxconf
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gtk+ (Show other bugs)
6.1
All Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 4376 5444 8130 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-02 12:09 EDT by Jan Carlson
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-18 02:50:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Carlson 1999-08-02 12:09:05 EDT
Start linuxconf and click "Basic Host information".
This error appears 5 times:

Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file
gtkwidget.c: line 1592 (gtk_widget_map): assertion
`GTK_WIDGET_VISIBLE (widget) == TRUE' failed.

All RH6 updates installed as of Aug 1.
This error did not occur until the recent gnome updates.
Comment 1 David Lawrence 1999-08-02 13:38:59 EDT
I have been able to replicate this problem on a 6.0 machine with gnome
updates installed.
Comment 2 Elliot Lee 1999-08-02 20:24:59 EDT
This is a gtk+ that gnome-linuxconf touched. I've changed
gnome-linuxconf not to touch it, and Owen is fixing the bug in gtk+.
Comment 3 Michael K. Johnson 1999-08-03 11:13:59 EDT
Reopened until we have a package with the new gtk+.  A new
gnome-linuxconf would also fix the problem.  We'll mark it
resolved when we have created one or both of the packages.
Comment 4 Michael K. Johnson 1999-08-28 14:35:59 EDT
gtk+-1.2.3-5 in RawHide *should* fix this.
Comment 5 Elliot Lee 1999-09-01 13:27:59 EDT
*** Bug 4376 has been marked as a duplicate of this bug. ***

I am getting multiple errors n console when exiting from
gnome:
Error message from remadmin :Gtk-CRITICAL **: file
gtkwidget.c: line 1592 (gtk_w
idget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE'
failed.
rm: cannot remove `/root/.gnome//gmc-qDubat': No such file
or directory

I am using rawhide-release-19990730-1.noarch.rpm



------- Additional Comments From gafton@redhat.com  08/23/99 20:54 -------
Assigned to Owen.
Comment 6 Michael K. Johnson 1999-09-19 18:36:59 EDT
I believe that the latest gtk update we released does fix this.
The workaround will be in the new gnome-linuxconf package in 6.1
and the next rawhide as well, so either way it should be fixed.

------- Additional Comments From   10/12/99 18:31 -------
This is still giving me problems on my clean 6.1 installation. The
error message is now:

Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line
1584 (gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE'
failed.

I notice that this error message appears once for every tab in the
linuxconf window (e.g. selecting "basic host information" generates 5
errors - one for each of "Host name", "Adapter 1", "2", "3" & "4")

Let me know if you need any information about my system.
Comment 7 Jan Carlson 1999-12-22 21:46:59 EST
THE BUG STILL EXISTS IN RH6.1 with or without
all official updates.  It is very prominent in the
xterm if you type 'linuxconf' in an xterm, and click
'Basic Host Information'.

5 FATAL ERROR MESSAGES FROM GTK, same as when first reported.
Comment 8 Nalin Dahyabhai 2000-01-06 13:04:59 EST
*** Bug 5444 has been marked as a duplicate of this bug. ***
Comment 9 Nalin Dahyabhai 2000-01-07 12:59:59 EST
*** Bug 8130 has been marked as a duplicate of this bug. ***
Comment 10 Nalin Dahyabhai 2000-01-12 10:25:59 EST
This should be fixed in gnome-linuxconf-0.23-1, which is in Raw Hide.  Please
let us know if it solves the problem for you.
Comment 11 Jaroslaw Sosnicki 2000-01-12 21:55:59 EST
It works. Thanks!
Comment 12 Jan Carlson 2000-01-13 03:03:59 EST
But rawhide gnome-linuxconf-0.23-1 is identical in version,
name and content to gnome-linuxconf-0.23-1 in original RH6.1!

$ rpm -qip gnome-linuxconf-0.23-1.i386.rpm
Name        : gnome-linuxconf              Relocations: (not relocateable)
Version     : 0.23                              Vendor: Red Hat Software
Release     : 1                             Build Date: Sun 19 Sep 1999 06:34:33
PM EDT
Install date: (not installed)               Build Host: porky.devel.redhat.com
Group       : Applications/System           Source RPM:
gnome-linuxconf-0.23-1.src.rpm
Size        : 334626                           License: GPL
Packager    : Red Hat Software <http://developer.redhat.com/bugzilla>
URL         : http://www.gnome.org
Summary     : The GNOME front-end for linuxconf.
Description :
[snip]

I got from the right place.  ncftp says:
  Logged in to
rawhide.redhat.com.
  Current remote directory is /pub/rawhide/i386/RedHat/RPMS

I run RH6.1 with all updates and RH6.1Gotchas fixes installed,
(and with rawhide gnome-linuxconf-0.23-1 too, which naturally
makes no difference).  I do not have everything in rawhide
installed.

I still see the following errors when I type 'linuxconf' in an xterm
and click "Basic Host Information":

# linuxconf
Error message from remadmin :
Error message from remadmin :Gdk-WARNING **: locale not supported by C library
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.
Error message from remadmin :
Error message from remadmin :Gtk-CRITICAL **: file gtkwidget.c: line 1584
(gtk_widget_map): assertion `GTK_WIDGET_VISIBLE (widget) == TRUE' failed.
Comment 13 Nalin Dahyabhai 2000-01-13 07:51:59 EST
My mistake.  The fixes are in gnome-linuxconf-0.24-1, which should be part
of the next version of Raw Hide, and is up to date wrt the CVS tree.
Comment 14 Jan Carlson 2000-01-18 02:50:59 EST
gnome-linuxconf-0.24-1 from rawhide does fix the problem for me.

Note You need to log in before you can comment on or make changes to this bug.