Bug 431500 - Installation on IDE with > 15 partitions fails. (Exception raised)
Installation on IDE with > 15 partitions fails. (Exception raised)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-04 20:58 EST by Graeme Gill
Modified: 2009-05-29 13:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-05 16:58:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graeme Gill 2008-02-04 20:58:05 EST
Description of problem:

Fedora Core 8 fails to install on a system using an IDE (SATA) driver with
more than 15 partitions, even when attemting to install to a partition
less than or equal to 15. The kernel is supposed to be able to
handle up to 32 partitions on an IDE driver, and other Linux instalations
(ie. Ubuntu) sucessfully install on this system.

The system uses:

 ASUS P5K-V Intel chipset motherboard
 500GB SATA hard drive
 Pioneer SATA DVD RW drive

The driver has 3 normal partitions for the boot manager
and 2 MSWindows versions, and 15 extended partitions for Linux
of about 25GB each.
(This is an application test machine for testing and debugging
 an application on the various operating system versions. I am
 unable to continue with the task of getting this application
 working on Fedora if I am unable to install it). 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Configure an IDE (SATA) driver with more than 15 partions
2. Attempt to install Fedora Core 8
3.
  
Actual results:


Expected results:


Additional info:

Transcibed exception information (unable to cut and paste)

anaconda 11.3.0.50 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/partedUtils.py", line 1242, in OpenDevices
    for line in exc.splitlines():
  File "/usr/lib/anaconda/fsset.py", line 116, in createLabel
    diskset.openDevices()
Comment 1 r c 2008-02-27 16:50:23 EST
Same problem occurs even if the drive with > 15 partitions is not involved in
the installation:

IDE/PATA 0 /dev/sdc (formerly /dev/hda) has > 15 partitions
IDE/PATA 1 ......
IDE/PATA 2 (DVD)
IDE/PATA 3 ......

SATA 0 /dev/sda
SATA 1 /dev/sdb   <== Target of the installation

Target is ext3 partition /dev/sdb12.  Source is ....iso on /dev/sda6.
Installation warns that a drive has > 15 partitions, do you want to continue? <yes>

Crashes just before packages are copied.
(write detail to floppy failed too)

Tried disabling PATA drives in BIOS - no effect, anaconda still recognizes them.
Workaround - physically unplug PATA0, 1, 3.  Installation runs cleanly.

Comment 2 Andy Lindeberg 2008-06-03 13:15:28 EDT
I believe this bug (or something similar) has been reported in F9 as well, but
have you tried installing the latest release?
Comment 3 David Cantrell 2008-08-05 16:58:26 EDT
The 15 partition limit is imposed by libata, which is in the kernel in Fedora.  We are bound by those limitations.  Use LVM or use fewer partitions.
Comment 4 Chris Lumens 2009-05-29 13:18:26 EDT
This is now fixed as of kernel 2.6.28.  Please see bug 465231.

Note You need to log in before you can comment on or make changes to this bug.