Bug 431556 - All bash scripts hang when starting on real tty
All bash scripts hang when starting on real tty
Status: CLOSED DUPLICATE of bug 172059
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
Depends On:
Blocks: 622981
  Show dependency treegraph
Reported: 2008-02-05 08:41 EST by Björn Gerhart
Modified: 2010-08-10 19:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 622981 (view as bug list)
Last Closed: 2008-02-05 09:56:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patches unicode_start to use /bin/sh instead of /bin/bash (285 bytes, application/octet-stream)
2008-02-05 08:41 EST, Björn Gerhart
no flags Details

  None (edit)
Description Björn Gerhart 2008-02-05 08:41:00 EST
+++ This bug was initially created as a clone of Bug #172059 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.12) Gecko/20050922
Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Bash scripts hang, running "bash -x" shows that they are hanging running a
command unicode_start

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start X, but do not login
2. <ctrl-alt-f1>
3. login to terminal session as root
  Attempt to run any bash script

Actual Results:  Script didn't start

Expected Results:  script should have started

Additional info:

I attempted to capture the output using 'script' to submit here as evidentce but
then the program ran fine, presumably because the output was a pty rather than a

-- Additional comment from bjoern.gerhart@wincor-nixdorf.com on 2007-11-09 05:19
EST --
Patch is created for modifying kbd-1.12-10.fc4.1.src.rpm. It just modifies the
very first line of unicode_start to #!/bin/sh.
(see also following issue: https://issues.rpath.com/browse/RPL-255)
Comment 1 Björn Gerhart 2008-02-05 08:41:00 EST
Created attachment 293995 [details]
Patches unicode_start to use /bin/sh instead of /bin/bash
Comment 2 Björn Gerhart 2008-02-05 09:56:50 EST

*** This bug has been marked as a duplicate of 172059 ***

Note You need to log in before you can comment on or make changes to this bug.