Bug 622981 - Running unicode_start can hang system
Summary: Running unicode_start can hang system
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kbd   
(Show other bugs)
Version: 5.5
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Vitezslav Crhonek
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords:
Depends On: 431556
Blocks: 743405 668957
TreeView+ depends on / blocked
 
Reported: 2010-08-10 23:51 UTC by Bryan Mason
Modified: 2018-11-30 22:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No Documentation needed
Story Points: ---
Clone Of: 431556
Environment:
Last Closed: 2013-01-08 07:07:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0015 normal SHIPPED_LIVE kbd bugfix update 2013-01-07 15:30:00 UTC

Description Bryan Mason 2010-08-10 23:51:26 UTC
+++ This bug was initially created as a clone of Bug #431556 +++

+++ This bug was initially created as a clone of Bug #172059 +++

Description of problem:

    Running "BASH_ENV=~/.bashrc TERM=linux /bin/unicode_start"
    on physical console will not return.

Version-Release number of selected component (if applicable):

    kbd-1.12-21.el5

How reproducible:

    100%

Steps to Reproduce:

    1. Switch to a real virtual terminal (i.e. not ssh or virsh console).
    2. Run "TERM=linux BASH_ENV=~/.bashrc /bin/unicode_start"

Actual Results:

    Command never returns.

Expected Results:
 
    Command should return.

Additional info:

    The problem is that setting BASH_ENV=~/.bashrc runs /etc/profile,
    which sources /etc/profile.d/lang.sh.  If TERM=linux, lang.sh runs
    /bin/unicode_start sending the whole process into an infinite
    loop.

    The resolution is to change the first line of /etc/unicode_start
    from "#!/bin/bash" to "#!/bin/sh".  This seems to be the way
    upstream (Fedora 12, at least) is written.

Comment 5 RHEL Product and Program Management 2011-05-31 14:04:39 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 7 RHEL Product and Program Management 2011-09-23 00:26:23 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 8 RHEL Product and Program Management 2012-04-19 11:47:46 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 12 Alex Sersen 2012-05-08 13:18:08 UTC
For reproducer take a look at #c0

new version:

$ TERM=linux BASH_ENV=~/.bashrc /bin/unicode_start &>/dev/null && echo $?
$ 0

Comment 13 Vitezslav Crhonek 2012-05-22 09:51:08 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Documentation needed

Comment 15 errata-xmlrpc 2013-01-08 07:07:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0015.html


Note You need to log in before you can comment on or make changes to this bug.