Bug 431589 - Missing ndesk-dbus dependencies
Missing ndesk-dbus dependencies
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-do (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: David Nielsen
Fedora Extras Quality Assurance
:
: 431462 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-05 12:48 EST by Edouard Bourguignon
Modified: 2008-02-12 23:58 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.3.0.1-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 23:58:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Edouard Bourguignon 2008-02-05 12:48:05 EST
Description of problem:

gnome-do requires ndesk-dbus and ndesk-dbus-glib to be installed but those
packages are missing in the Requires inside the spec file. Is there any reason?

Version-Release number of selected component (if applicable):

gnome-do-0.3.0.1-3.fc8

How reproducible:

static

Steps to Reproduce:
1. yum install gnome-do
2. run gnome-do
3. lots of mono errors: ndesk-dbus-glib missing etc
  
Actual results:

gnome-do can't be executed

Expected results:

gnome-do should run properly, installing this package should bring ndesk-dbus
and ndesk-dbus-glib as dependencies

Additional info:

Installing ndesk-dbus and ndesk-dbus-glib by hand works great. gnome-do is
really great
Comment 1 David Nielsen 2008-02-06 00:54:09 EST
Both are build dependencies so they should be automatic runtime deps as well. I
suspect this is a case of RPM screwing me. I'm queuing up a build where these
are forced runtime deps even when they shouldn't have to be, that will fix it.
The words ugly and wrong comes to mind with regards to this "fix" but hey, RPM
seems to want a bit of hands holding.

The queued build for F-8 is here, once this hits the repos the bug will
automatically close.
http://koji.fedoraproject.org/koji/taskinfo?taskID=398275

Thank you for reporting this problem.
Comment 2 Fedora Update System 2008-02-06 01:03:09 EST
gnome-do-0.3.0.1-5.fc8 has been submitted as an update for Fedora 8
Comment 3 JM 2008-02-07 13:32:11 EST
And the gnome-do RPM needs the RPM gtk-sharp2-devel without gtk-sharp2-devel the
command

pkg-config --variable=libdir tomboy-addins

in /usr/bin/gnome-do

fails or better it returns an empty string. I for example have no -devel RPMs on
one of my system and there /usr/bin/gnome-do can't find the libtomboy.so and so
it can't bind the Hotkey to <Super>Space.
Comment 4 Gordon Messmer 2008-02-08 04:10:43 EST
It's possible that /usr/lib/rpm/mono-find-requires isn't detecting dependencies
properly.  Try doing 'rpmbuild -bi gnome-do', and then run mono-find-requires by
hand.  See what it outputs.  If the output doesn't include
mono(NDesk.DBus.GLib), then you might want to file a bug in the rpm-build package.

For the time being, though, it doesn't matter whether or not mono-find-requires
works, you'll still need to specify the names of the ndesk packages.  Multiple
packages "provide" 'mono(NDesk.DBus.GLib)', though I don't believe that they'll
actually make it available for other applications use:

$ yum whatprovides 'mono(NDesk.DBus.GLib)'
banshee.x86_64 : easily import, manage, and play selections from your music
collection
f-spot.x86_64 : Photo management application
muine.x86_64 : Music Player for GNOME
ndesk-dbus-glib.x86_64 : Provides glib mainloop integration for ndesk-dbus
Comment 5 David Nielsen 2008-02-08 09:01:07 EST
My setup elected to commit suicide, I'll get right on this once I get back on a
 working Fedora machine.
Comment 6 David Nielsen 2008-02-08 09:03:28 EST
*** Bug 431462 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2008-02-12 23:58:20 EST
gnome-do-0.3.0.1-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.