Bug 43163 - disk druid and fdisk both allow more than 15 partitions on scsi drives
disk druid and fdisk both allow more than 15 partitions on scsi drives
Status: CLOSED DUPLICATE of bug 44115
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-01 13:01 EDT by Lisa Rojas
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-01 14:21:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lisa Rojas 2001-06-01 13:01:41 EDT
Description of Problem:
When installing a new server with 7.1, I found a nasty little bug.  I accidentally put 16 partitions on a scsi drive.
neither fdisk OR diskdruid caught the error. The installation went fine until it came time to format the new filesystems. 
then it just hung.  Out of curiosity I used a boot diskette to see what happened and it appeared that with the exception of /,
none of the extended partitions got mounted.  They did have entries in fstab, just not in mtab.  At the very least, disk druid 
ought to error out when you try to give a mount point to sda#'s that are over the scsi limitation.

How Reproducible: ALWAYS


Steps to Reproduce:
1. see problem desciption
2. 
3. 

Actual Results: see problem description


Expected Results:
see problem description

Additional Information:
	Hardware FYI - Dell poweredge 2400; 5 16G drives; 3 containers (2 at raid1 and 1 at raid0) adaptec 7x card.
Comment 1 Brent Fox 2001-06-14 11:53:57 EDT

*** This bug has been marked as a duplicate of 44115 ***

Note You need to log in before you can comment on or make changes to this bug.