Bug 431661 - No kernel packages were installed
No kernel packages were installed
Status: CLOSED DUPLICATE of bug 388231
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 03:59 EST by Duncan Innes
Modified: 2008-02-08 17:38 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-08 17:38:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/anaconda.log (34.32 KB, text/plain)
2008-02-08 14:30 EST, Duncan Innes
no flags Details
/root/install.log (43.61 KB, text/plain)
2008-02-08 14:31 EST, Duncan Innes
no flags Details

  None (edit)
Description Duncan Innes 2008-02-06 03:59:51 EST
Description of problem:
I'm rebuilding my F8 desktop using brand new SCSI disks.  Fedora is being 
installed on the boot drive.  At the end of every install, the error "No kernel 
packages were installed" is displayed before the reboot message.

Version-Release number of selected component (if applicable):


How reproducible:
Every install I've tried over the last 2 days

Steps to Reproduce:
1. Install Fedora 8 from i386 DVD
  
Actual results:
"No kernel packages were installed" error at end of install


Expected results:
Good install

Additional info:
On reboot, the machine complains there is no OS on the disk (can't remember the 
full wording).

I've booted into rescue mode via the install DVD and done a re-insall of grub 
on /dev/sda.  This lets grub run when I boot up, but there is no menu, no 
options etc.

I've looked at the filesystem and found kernel packages WERE installed.  The 
files that are missing appear to be /boot/grub/grub.conf 
and /boot/grub/menu.lst (at least).

As a fix, I will try creating these files by hand (I have a working laptop 
installation to copy from).

I did have the error the last time I re-installed F8 from scratch, but can't 
remember how I got around it.
Comment 1 Jeremy Katz 2008-02-06 11:55:43 EST
Is this with a full install?  Can you switch to tty2 when this occurs (or go
into rescue mode) and grab /mnt/sysimage/root/install.log and /tmp/anaconda.log
(or /mnt/sysimage/var/log/anaconda.log from rescue mode)?
Comment 2 Duncan Innes 2008-02-08 14:28:30 EST
I've managed to coax the install into working by booting the DVD into rescue
mode, creating and hand editing the relevant grub.conf files and reinstalling grub.

I reinstalled grub first, but that left me with no grub menu.  Providing the
grub.conf file (there were no /etc/grub.conf, /boot/grub/grub.conf or
boot/grub/menu.lst files, so I put the links and the file in place and copied
the grub.conf from my laptop) allowed me to boot grub and select options from
the menu.

Comment 3 Duncan Innes 2008-02-08 14:30:47 EST
Created attachment 294402 [details]
/var/log/anaconda.log
Comment 4 Duncan Innes 2008-02-08 14:31:22 EST
Created attachment 294404 [details]
/root/install.log
Comment 5 Duncan Innes 2008-02-08 14:37:46 EST
"Is this a full install?"

Sorry - forgot to answer this.  The install was "fullsome", but I didn't include
all packages.  There was nothing excluded, however, that ought to have left grub
off the disk.  In fact, grub WAS installed as the rpm was in the package list, I
just needed the config files and to grub-install it.  Does the grub-install put
it in the MBR or Boot Partition (wherever I've selected it goes)?

The install went to near completion before giving me the error.  After clicking
OK, I was then presented with the normal reboot message that follows all
successful installs.

I tried several times with several different package lists.  One thing I thought
might be the case is that I've got 6Gb of RAM in the machine - perhaps Fedora
was failing to install fully because of this?  I removed 2Gb RAM to take it to 4
but it still failed.  In desperation, I removed a further 2Gb to take it to 2Gb
which should be more than adequate to do what I needed.

None of the options I tried resulted in a successful install.  As this is my
main machine, I may not be able to test further points, but can provide any of
the log files that may be required.  I do have an extra disk in the system for
further testing, but I'd banked on using this for Fedora 9 Alpha testing.
Comment 6 Jeremy Katz 2008-02-08 17:38:29 EST

*** This bug has been marked as a duplicate of 388231 ***

Note You need to log in before you can comment on or make changes to this bug.