Bug 431766 - The netlabelctl command fails to run due to newer libnl package
The netlabelctl command fails to run due to newer libnl package
Product: Fedora
Classification: Fedora
Component: netlabel_tools (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Karl Wirth
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-02-06 15:49 EST by Paul Moore
Modified: 2008-11-26 12:37 EST (History)
2 users (show)

See Also:
Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-11-26 12:37:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Paul Moore 2008-02-06 15:49:55 EST
Description of problem:
The netlabelctl command fails to run due to changes made to the libnl package 
which affect the libnl API.  When running the netlabelctl command users see 
the following error:

 # netlabelctl -p mgmt version
 netlabelctl: symbol lookup error: netlabelctl: undefined symbol:  

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. netlabelctl -p mgmt version
Actual results:
See above

Expected results:
No symbol lookup errors

Additional info:
A patch has been merged upstream which corrects this problem.

 * http://netlabel.svn.sourceforge.net/viewvc/netlabel?view=rev&revision=52
Comment 1 Steve Conklin 2008-02-06 16:28:50 EST
Thanks, I should be able to fix this tomorrow.
Comment 2 Steve Conklin 2008-02-07 16:52:06 EST
although this worked on a rawhide build from a week or so ago, it won't build in
the current rawhide. I probably won't be able to look at this again until Monday.
Comment 3 Paul Moore 2008-02-07 20:51:22 EST
You might try the latest bits from SVN, I'll also try to update my test 
machines to a more current rawhide and see what I can do.
Comment 4 Paul Moore 2008-02-08 13:35:45 EST
The problem turned out to be a combination of a bump in libnl to version 1.1 
as well as some changes to the system's header files.  I can confirm that the 
latest SVN bits do compile on today's rawhide.  The relevant changes are here:

 * http://netlabel.svn.sourceforge.net/viewvc/netlabel?view=rev&revision=57
Comment 5 Dan Williams 2008-03-06 19:13:59 EST
I tried to find all users of libnl before updating, must have missed
netlabel_tools.  I'm updating F-7 too; will probably need a rebuild there.  See
Bug #401761.
Comment 6 Dan Williams 2008-03-06 19:19:06 EST
I can confirm that copying netlabel_tools-0.17-newlibnl.patch from the F-8
branch allows the F-7 version of netlabel_tools to build correctly.  If you
don't mind, I'll rebuild netlabel_tools and post an update to it.
Comment 8 Bug Zapper 2008-11-26 04:43:13 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 9 Jon Stanley 2008-11-26 12:37:18 EST
As this bug is in MODIFIED, Fedora believes that a fix has been committed that resolves the problem listed in this bug report.

If this is not the case, please re-open this report, noting the version of the package that you reproduced the bug against.

Thanks for the report!

Note You need to log in before you can comment on or make changes to this bug.