Bug 431837 - system-config-printer Version 0.7.74.10 & AppSocket/HP JetDirect
system-config-printer Version 0.7.74.10 & AppSocket/HP JetDirect
Status: CLOSED DUPLICATE of bug 431252
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-07 04:26 EST by Markus Maletz
Modified: 2008-02-07 04:42 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-07 04:42:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Maletz 2008-02-07 04:26:48 EST
Description of problem:

adding a new printer is impossible (in my case AppSocket/HP JetDirect)

Version-Release number of selected component (if applicable):
system-config-printer Version 0.7.74.10

How reproducible:

i started system-config-printer out of a shell and tried to add a new printer
type hp-jet direct

i typed the ip-address in the hostname field and pushed the next button. 
Nothing happend (the mouse-cursor was in "the sandclock mode"
 

Steps to Reproduce:
1.
2.
3.
  
Actual results:
in this case the shell output

[root]# system-config-printer
fetchDevices
queryDevices
Lock acquired for devices thread
Devices thread started
Connecting (devices)
Fetching devices
Closing connection (devices)
Releasing devices lock
Acquiring devices lock
Got devices
queryPPDs
Lock acquired for PPDs thread
PPDs thread started
Connecting (PPDs)
Fetching PPDs
Closing connection (PPDs)
Releasing PPDs lock
fetchPPDs
Acquiring PPDs lock
Got PPDs
Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 2263,
in on_btnNPForward_clicked
    self.nextNPTab()
  File "/usr/share/system-config-printer/system-config-printer.py", line 2298,
in nextNPTab
    host = self.getNetworkPrinterMakeModel(self.device)
  File "/usr/share/system-config-printer/system-config-printer.py", line 2558,
in getNetworkPrinterMakeModel
    debugprint (host + ": " + cmd)
NameError: global name 'debugprint' is not defined


Expected results:


Additional info:
Comment 1 Tim Waugh 2008-02-07 04:42:45 EST

*** This bug has been marked as a duplicate of 431252 ***

Note You need to log in before you can comment on or make changes to this bug.