Bug 431872 - xorg-x11-drv-ati will not work on primary display on my powerbook
xorg-x11-drv-ati will not work on primary display on my powerbook
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
powerpc Linux
high Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-07 10:22 EST by Josef Bacik
Modified: 2009-07-14 12:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:42:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
normal Xorg.0.log (32.33 KB, text/plain)
2008-02-07 15:01 EST, Josef Bacik
no flags Details
xorg.conf (676 bytes, text/plain)
2008-02-07 15:01 EST, Josef Bacik
no flags Details
Xorg.0.log with no xorg.conf (17.86 KB, text/plain)
2008-02-07 15:02 EST, Josef Bacik
no flags Details
good log using older driver (66.95 KB, text/plain)
2008-02-20 17:03 EST, John Ellson
no flags Details
bad log using new ati driver (7.11 KB, text/plain)
2008-02-20 17:04 EST, John Ellson
no flags Details
/var/log/Xorg.0.log with radeon-6.7.196-faster-ddc.patch (breaks) (38.73 KB, text/plain)
2008-04-10 02:44 EDT, Frank Arnold
no flags Details
/var/log/Xorg.0.log without radeon-6.7.196-faster-ddc.patch (works) (43.85 KB, text/plain)
2008-04-10 02:45 EDT, Frank Arnold
no flags Details
lspci output (9.54 KB, text/plain)
2008-10-01 00:39 EDT, John Reiser
no flags Details
Xoreg.0.log (56.76 KB, text/plain)
2008-10-01 00:41 EDT, John Reiser
no flags Details

  None (edit)
Description Josef Bacik 2008-02-07 10:22:25 EST
Description of problem:
When trying to install the ppc version of F9 Alpha on my G4 Powerbook it goes along fine, 
goes to start anaconda, and I get a blank screen.  I can't switch to any of the virtual 
consoles (though I'm not sure if I can do that at that point normally anyway) but I can hit 
ctrl+alt+del and it will drop me out of that and reboot my box.  The messages I see are 
this

Running anaconda 11.4.0.28, the Fedora system installer - please wait...
Probing for video card:    ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

and then when I hit ctlr+alt+del I see this

Attempting to start native X server
Waiting for X server to start...log located in /tmp/X.log
1...2...3...4...5... X server started successfully.
22:59:49 Starting graphical installation...
mini-wm: Fatal IO error 11 (Resource temporarily unavailable) on X server :1.0.
anaconda: Fatal IO error 11 (Resource temporarily unavailable) on X server :1.0.
install exited abnormally [1/1]

followed by the normal rebooting stuff.  I'm going to try a text install to see if that works 
better.
Comment 1 Matěj Cepl 2008-02-07 13:22:35 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Josef Bacik 2008-02-07 15:01:24 EST
Created attachment 294260 [details]
normal Xorg.0.log

these files are all after f9 installed, I'm still seeing the same problem.
Comment 3 Josef Bacik 2008-02-07 15:01:49 EST
Created attachment 294261 [details]
xorg.conf
Comment 4 Josef Bacik 2008-02-07 15:02:15 EST
Created attachment 294262 [details]
Xorg.0.log with no xorg.conf
Comment 5 Josef Bacik 2008-02-07 15:02:47 EST
btw if i run startx i hear the sound for logging into kde, so it seems the window manager is 
starting fine, I just have a blank screen.
Comment 6 Josef Bacik 2008-02-07 17:06:41 EST
updated everything and I'm still getting the blank screen.
Comment 7 Josef Bacik 2008-02-11 11:26:09 EST
btw my video worked fine on this box in F8 with the updates from like 3 or 4 weeks ago.
Comment 8 Josef Bacik 2008-02-20 11:21:06 EST
with the new ati drivers its still not working, tho I noticed that kde still was coming up 
normally, and the screen looked like it does when i have an external monitor hooked up to 
it (which I don't).  So i hooked an external monitor up, started x, and it came up great on 
the external monitor, but still with the blank screen on my laptop.
Comment 9 John Ellson 2008-02-20 16:53:23 EST
I believe I have this same bug on an hp desktop machine running fedora-8 with
xorg-x11-drv-ati-6.7.197-1

Reverting to xorg-x11-drv-ati-6.7.195-3 fixes the problem.

I think its switching the output to the DVI connector which has nothing attached
to it.

I have no xorg.conf.  I'll attach good and bad Xorg.0.logs next.
Comment 10 John Ellson 2008-02-20 17:03:13 EST
Created attachment 295454 [details]
good log using older driver
Comment 11 John Ellson 2008-02-20 17:04:11 EST
Created attachment 295455 [details]
bad log using new ati driver
Comment 12 Josef Bacik 2008-02-21 12:22:20 EST
updated to the new xorg-x11-drv-ati-6.8.0-1.fc9 this morning and the problem persists.
Comment 13 Josef Bacik 2008-03-03 11:19:12 EST
updated to the new version this morning and still no go, new problem tho, unless I disable 
selinux X won't even start, it always exits out (this is in permissive).  With it disabled I get 
the same behavior as before.
Comment 14 Josef Bacik 2008-03-17 10:53:52 EDT
several updates have gone by and its still not working.
Comment 15 Josef Bacik 2008-03-24 16:55:39 EDT
updated to beta and its still doing the same thing.
Comment 16 Josef Bacik 2008-03-24 17:00:39 EDT
fixing the title to something more appropriate.
Comment 17 Frank Arnold 2008-03-25 15:27:37 EDT
Looks like I have the same problem. The screen isn't totally black for me,
instead it does some blooming. Additionally, my NumLock LED turns on. When
pressing F6 the NumLock goes off. Then I'm able to switch to the VTs. Normally I
would have to press fn + F6 to turn off NumLock.

* My hardware should be very similar if not the same (PowerBook5,6)
* Installation is Rawhide as of 03/25/2008
* I saw this problem about two months ago and used F-8 X.org packages on top of
  Rawhide since then

I'm not entirely sure, but I think the last time I saw such blooming was with
bug 187083 .
Comment 18 Frank Arnold 2008-03-25 15:57:46 EDT
(In reply to comment #17)
> I'm not entirely sure, but I think the last time I saw such blooming was with
> bug 187083 .

I just found the right one: It was bug 186239. Unfortunately, no real solution
there.
Comment 19 Josef Bacik 2008-03-28 11:27:28 EDT
xorg-x11-drv-ati-6.8.0-5 still no worky.
Comment 20 John Ellson 2008-03-28 12:25:16 EDT
xorg-x11-drv-ati-6.8.0-1  (Fedora 8) still no worky either, on a:
  Vendor: Hewlett-Packard
  System: HP dx5150 SFF 
  Form factor: desktop
with:
  (4098:22868:4156:12297) pci, Unknown, VIDEO, RS480 [Radeon Xpress 200G Series]

Last working driver on this machine was:
    xorg-x11-drv-ati-6.7.195-3.fc8.x86_64

Comment 21 Dave Airlie 2008-03-30 21:38:14 EDT
can all the me toos start another bug?

this bug is powerbook specific.

if you haven't a powerbook please log another bug.

reporter can you take a look at the Option "MacModel" in the radeon man page,
and try a few options to see if one works for you? we have some autodetect code
for macs that may be doing it wrong.
Comment 22 Josef Bacik 2008-03-31 13:41:56 EDT
sorry I guess i should have said this before, but when I've been testing I've 
been testing with no options and with MacModel set to powerbook and 
powerbook-internal incase the powerbook option wasn't doing what it was 
supposed to do and it doesnt work.  I have also tried (originally tho, not 
recently) DRI off, setting the Option "PanelSize" and the Option "NoAccel" 
just for fun, all to no avail.
Comment 23 Josef Bacik 2008-04-01 16:48:24 EDT
there was an updated driver today, still isn't working.
Comment 24 Josef Bacik 2008-04-08 09:55:27 EDT
there was an updated driver this weekend, still isn't working.
Comment 25 Dave Airlie 2008-04-09 01:10:27 EDT
does powerbook-duallink help either?

I'm a bit lost all on all these powerbooks :)
Comment 26 Dave Airlie 2008-04-09 01:59:16 EDT
okay I've asked upstream to take a look the lack of DDC is messing up, we should
however be able to to DDC on this notebook panel

PanelSize should fix it though..

I don't suppose you have a log from when this used to work? we may have broken
DDC recently and not known.
Comment 27 Frank Arnold 2008-04-09 09:58:17 EDT
Did a yum update today, and X is working again for me on a PowerBook5,6.

This was the last update I did, which didn't work:
Apr 04 19:36:30 Updated: xorg-x11-server-common-1.4.99.901-16.20080401.fc9.ppc
Apr 04 19:47:01 Updated: xorg-x11-proto-devel-7.3-11.fc9.noarch
Apr 04 19:53:33 Updated: xorg-x11-server-Xorg-1.4.99.901-16.20080401.fc9.ppc
Apr 04 19:53:47 Updated: xorg-x11-drv-keyboard-1.3.0-2.fc9.ppc
Apr 04 19:53:57 Updated: xorg-x11-drv-ati-6.8.0-9.fc9.ppc

And this is todays update which fixes the issue for me:
Apr 09 13:51:08 Updated: xorg-x11-server-common-1.4.99.901-18.20080401.fc9.ppc
Apr 09 13:52:04 Updated: xorg-x11-proto-devel-7.3-12.fc9.noarch
Apr 09 13:57:27 Updated: xorg-x11-apps-7.3-3.fc9.ppc
Apr 09 13:58:28 Updated: xorg-x11-server-Xorg-1.4.99.901-18.20080401.fc9.ppc
Apr 09 13:58:59 Updated: xorg-x11-drv-vesa-1.3.0-14.20080404.fc9.ppc
Apr 09 13:59:07 Updated: xorg-x11-drv-ati-6.8.0-10.fc9.ppc
Apr 09 14:03:11 Updated: xorg-x11-drivers-7.3-4.fc9.ppc
Comment 28 Josef Bacik 2008-04-09 11:21:10 EDT
setting PanelSize doesnt fix it.  I've tried a couple other things, ReverseDDC 
looked promising as it seems thats whats happening, its just choosing the 
wrong output, but no go.  I'm on the same package versions as Frank and still 
nothing.  Unfortunately I don't have the logs from when it was working, as I 
just reinstalled.  If you think it would be helpful I can go back.
Comment 29 Josef Bacik 2008-04-09 12:59:47 EDT
ok pulling from the git tree 

http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-ati.git;a=summary

and building the driver manually makes it work.
Comment 30 Frank Arnold 2008-04-09 16:39:19 EDT
And now it gets *very* interesting...

I only thought it would be fixed. Right before I did the update today I've
rebuilt the recent xorg-x11-drv-ati-6.8.0-1 from Fedora 8 and installed it,
which worked. Because it is 6.8.0 too, I thought I try to update to the recent
Rawhide package. I didn't reboot afterwards, only restarted X which worked too.
And now that I'm home from work I'm seeing the same error again... looks like
something for a PPC guru like dwmw2.
Comment 31 Frank Arnold 2008-04-09 17:02:29 EDT
> And now that I'm home from work I'm seeing the same error again... looks like
> something for a PPC guru like dwmw2.

... or not.
I just rebuilt xorg-x11-drv-ati-6.8.0-10 locally and it does not work. Then I
rebuilt xorg-drv-ati-6.8.0-1 from Fedora 8 again, which works. So we only need
to look at the differences of both packages :)
Comment 32 Frank Arnold 2008-04-09 18:11:13 EDT
radeon-6.7.196-faster-ddc.patch it is. Excluded this one, rebuilt the package,
rebooted -- just to be sure, and got my X working again ;)
Comment 33 Dave Airlie 2008-04-09 19:06:34 EDT
Oh messy..

can you attach a logs, one with that patch and one without?

I'd be interested to figure out what is going wrong...
Comment 34 Frank Arnold 2008-04-10 02:44:05 EDT
Created attachment 301933 [details]
/var/log/Xorg.0.log with radeon-6.7.196-faster-ddc.patch (breaks)
Comment 35 Frank Arnold 2008-04-10 02:45:36 EDT
Created attachment 301935 [details]
/var/log/Xorg.0.log without radeon-6.7.196-faster-ddc.patch (works)
Comment 36 Dan Williams 2008-04-10 18:18:21 EDT
the faster-ddc patch is the likely cause of panel blooms on my iBook G3 800 too;
http://bigw.org/~dan/Xorg.0.log.  Blooms for about 2s every time X starts.
Comment 37 Bug Zapper 2008-05-14 01:03:40 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 38 John Reiser 2008-10-01 00:38:37 EDT
This bug prevents me from graphical install of Fedora 10 Beta.  The same box runs Fedora 9 just fine.  If I could, then I would change Version of this bug report to Rawhide, but bugzilla does not let me.

I attach output from lspci and Xorg.0.log running on Fedora 9.  The video card is ATI HD3650, the single monitor is 1024x768@60Hz.

This bug may be related to Bug 322541 "Fatal IO error 11 on exit of system-config-display".
Comment 39 John Reiser 2008-10-01 00:39:50 EDT
Created attachment 318161 [details]
lspci output

lspci; lspci -n; lspci -v
Comment 40 John Reiser 2008-10-01 00:41:32 EDT
Created attachment 318162 [details]
Xoreg.0.log

Xorg.0.log from successful use in Fedora 9.
Comment 41 Jóhann B. Guðmundsson 2008-12-01 05:47:57 EST
There have been bunch of bug fixes

Could you retest with the latest kernel 
( -132 at the time of this writing )

You can get the latest kernel build here
http://koji.fedoraproject.org/koji/buildinfo?buildID=72270 

And with the latest xorg-x11-drv-ati. 
( -60 at the time of this writing )

You can get the latest xorg-x11-drv-ati build here
http://koji.fedoraproject.org/koji/packageinfo?packageID=95

And report back if it either improves or fixes this issue..

Thanks.
Comment 42 John Ellson 2008-12-01 09:03:06 EST
I upgraded my HP desktop to fedora-10, it seems OK now using xorg-x11-drv-ati-6.9.0-54.fc10.x86_64

I can no longer test fedora-9, but I notice that its latest update is only to xorg-x11-drv-ati-6.8.0-19.fc9.x86_64.rpm
Comment 43 John Reiser 2008-12-01 17:35:09 EST
(In reply to comment #38)
> This bug prevents me from graphical install of Fedora 10 Beta. ...
> The video card is ATI HD3650, the single monitor is 1024x768@60Hz.

Fedora 10 final release works.
  kernel-2.6.27.5-117.fc10.x86_64
  xorg-x11-drv-ati-6.9.0-54.fc10.x86_64
01:00.0 VGA compatible controller: ATI Technologies Inc Mobilitiy Radeon HD 3600 Series
01:00.0 0300: 1002:9598
Comment 44 John Reiser 2008-12-01 17:49:51 EST
(In reply to comment #41)

> You can get the latest kernel build here
> http://koji.fedoraproject.org/koji/buildinfo?buildID=72270 

That's not enough:
	kernel-firmware >= 2.6.27.7-132.fc10 is needed by kernel-2.6.27.7-132.fc10.x86_64
and I cannot find such a package on rawhide mirror, etc.  Help?
Comment 45 Jóhann B. Guðmundsson 2008-12-02 03:06:32 EST
Take a look at the noarch section for the kernel 
it's there along with the doc package.

Are you on a PPC arch?

This bug was originally filed against PPC arch. 

It would be good to get some feedback from those that possess 
such HW.
Comment 46 Dave Airlie 2009-01-27 21:00:40 EST
Can the HD 3600 person move off the bug  and start a new one.

this bug is about a powerbook mac nothing to do with anything later.
Comment 47 John Reiser 2009-01-28 10:47:44 EST
(In reply to comment #46)
A Fedora10 install DVD that I composed last night does not have the problem with the HD 3600.  Graphical install from the DVD succeeded, instead of failing to display video at first switch to graphics mode (Comment #38.)
kernel-2.6.27.12-170.2.5.fc10.x86_64.rpm
xorg-x11-drv-ati-6.9.0-63.fc10.x86_64.rpm
Comment 48 Adam Williamson 2009-02-20 17:41:18 EST
From what I can see, ignoring all the stuff from people who are talking about completely different bugs, this shouldn't be in NEEDINFO state any more. All the information David asked for from people with the correct hardware, running the correct distro, has been provided.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 49 Bug Zapper 2009-06-09 19:31:05 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 50 Bug Zapper 2009-07-14 12:42:54 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.