Bug 431937 - FPE exception for hugemem vmcores
FPE exception for hugemem vmcores
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: diskdumputils (Show other bugs)
4.8
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: Takao Indoh
: Regression
: 431943 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-07 17:22 EST by Andrew Hecox
Modified: 2010-10-22 18:20 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0684
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:35:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simple switch of args to strstr (538 bytes, patch)
2008-02-07 17:26 EST, Andrew Hecox
no flags Details | Diff
log_buf_len %0 patch (483 bytes, patch)
2008-02-12 17:01 EST, Andrew Hecox
no flags Details | Diff
diskdumpmsg.patch applied to diskdumputils-1.4.1-3 (700 bytes, patch)
2008-02-13 10:00 EST, Dave Anderson
no flags Details | Diff

  None (edit)
Description Andrew Hecox 2008-02-07 17:22:05 EST
Description of problem:

diskdumpmsg fails when reading hugemem kernel cores.

Version-Release number of selected component (if applicable):

diskdumputils-1.4.1-2

may affect previous versions, not tested.

How reproducible:

create a vmcore file for a hugemem kernel, run diskdumpmsg vmcore.

Actual results:

Floating point exception.

Expected results:

kernel log buffer results.

Additional info:

The problem results from misordered arguments to strstr, patch forthcoming.
Comment 1 Andrew Hecox 2008-02-07 17:26:40 EST
Created attachment 294280 [details]
simple switch of args to strstr


patch attached, as discussed in:

https://www.redhat.com/archives/crash-utility/2008-February/msg00021.html
Comment 2 Dave Anderson 2008-02-08 08:57:29 EST
If it's not too late, can this be a 4.7 errata candidate?
Comment 3 RHEL Product and Program Management 2008-02-08 09:08:14 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Dave Anderson 2008-02-08 10:39:13 EST
(In reply to comment #4)
> Dave - do you think this is urgent enough to merit an exception and get
> into 4.7?
> 
> 
> This event sent from IssueTracker by sfolkwil 
>  issue 161392
>               

It was a regression that was introduced in the RHEL4-6 errata, in
which diskdumpmsg was changed from a python script to a C-file binary.
That new version could never have worked for a hugemem kernel. 
Comment 6 Issue Tracker 2008-02-08 11:21:39 EST
OK if it's a regression then we need to fix ASAP. Will file exception.
Thanks.


This event sent from IssueTracker by sfolkwil 
 issue 161392
Comment 9 Dave Anderson 2008-02-12 16:31:57 EST
When the qa_ack comes through, I will file the RHEL4.7 errata on your behalf,
and then follow it through to its release.

Tindoh, I can either: 
 
(1) create a patch for the current diskdumputils 1.4.1 package, or
(2) you can create a new base diskdumputils tar.gz file to replace
    the current diskdumputils-1.4.1.tar.gz. 

Which would you prefer?

Comment 10 Andrew Hecox 2008-02-12 17:01:07 EST
Created attachment 294703 [details]
log_buf_len %0 patch


check that log_buf_len is not zero before dividing by it.
Comment 11 Andrew Hecox 2008-02-12 17:03:05 EST
*** Bug 431943 has been marked as a duplicate of this bug. ***
Comment 12 Andrew Hecox 2008-02-12 17:05:26 EST
attaching second patch, from bz431943, to this issue. Both bz's were opened by
me, one for each patch. For simplicity, combining into one (this one).

The second patch simply checks that log_buf_len isn't zero before dividing by
it. If it is, the log_buf wasn't readable and the program exists, indicating such.
Comment 13 Takao Indoh 2008-02-12 17:55:36 EST
Hi Dave,

>(1) create a patch for the current diskdumputils 1.4.1 package, or

This is fine with me.

Takao
Comment 14 Dave Anderson 2008-02-13 09:57:33 EST
MODIFIED: CVS Tag: diskdumputils-1_4_1-3

porkchop:/mnt/redhat/brewroot/packages/diskdumputils/1.4.1/3
Comment 15 Dave Anderson 2008-02-13 10:00:19 EST
Created attachment 294795 [details]
diskdumpmsg.patch applied to diskdumputils-1.4.1-3
Comment 16 Dave Anderson 2008-02-13 10:40:32 EST
A RHEL4.7 errata cannot be filed until the following issues
are resolved; this is the error message from the errata tool:

>  There were problems with the following fields:
>
>  * Idsfixed Bug 431937 does not have the correct flags. Requires
>  rhel-4.7,devel_ack,qa_ack,pm_ack but only has rhel-4.7?, devel_ack+,
>  pm_ack+, blocker?, qa_ack?.

Comment 17 Dave Anderson 2008-02-14 08:57:53 EST
To whom it may concern:

  Requesting: rhel4-7+ and qa_ack+

Comment 22 errata-xmlrpc 2008-07-24 15:35:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0684.html

Note You need to log in before you can comment on or make changes to this bug.