Bug 431943 - FPE exception for hugemem vmcores (p2)
FPE exception for hugemem vmcores (p2)
Status: CLOSED DUPLICATE of bug 431937
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: diskdumputils (Show other bugs)
4.8
i386 Linux
low Severity low
: rc
: ---
Assigned To: Linda Wang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-07 17:43 EST by Andrew Hecox
Modified: 2008-02-12 17:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 17:03:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
validate log_buf_len (483 bytes, patch)
2008-02-07 17:43 EST, Andrew Hecox
no flags Details | Diff

  None (edit)
Description Andrew Hecox 2008-02-07 17:43:40 EST
related to:

https://bugzilla.redhat.com/show_bug.cgi?id=431937

in get_logbuf, diskdumpmsg does not check for a non-zero value of log_buf_len
before using it as a divisor. In cases where
read_int->read_buffer_sym->read_buffer cannot read the appropriate page,
log_buf_len is set to zero. On return, this causes a divide by zero exception.

This patch is one way of reporting an error without the FPE.

The patch in 431937 fixes the only case I know of where this actually happens;
accordingly, this patch is mostly cosmetic.
Comment 1 Andrew Hecox 2008-02-07 17:43:40 EST
Created attachment 294281 [details]
validate log_buf_len
Comment 2 Dave Anderson 2008-02-08 08:59:54 EST
I'm not sure why this can't be combined with BZ #431937, but in any case,
can this be a RHEL4.7 errata candidate?
Comment 3 RHEL Product and Program Management 2008-02-08 09:08:09 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Andrew Hecox 2008-02-12 16:38:16 EST
Dave -- would you like me to close this issue and just deal with it via the
related bz?
Comment 5 Dave Anderson 2008-02-12 16:42:34 EST
I think it makes more sense to do it that way -- but append your log_buf_len
patch above to the other bugzilla so that it doesn't get lost.
Comment 6 Andrew Hecox 2008-02-12 17:03:04 EST
closing, should be covered in https://bugzilla.redhat.com/show_bug.cgi?id=431937.

*** This bug has been marked as a duplicate of 431937 ***

Note You need to log in before you can comment on or make changes to this bug.