Bug 432065 - RFE: Add ext4 and xfs functionality to system-config-lvm
RFE: Add ext4 and xfs functionality to system-config-lvm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-lvm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Marek Grac
Fedora Extras Quality Assurance
: FutureFeature
: 508889 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-08 12:39 EST by Eric Sandeen
Modified: 2009-08-20 08:33 EDT (History)
15 users (show)

See Also:
Fixed In Version: system-config-lvm-1_1_8-1_fc12
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 08:33:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
initial patch (7.44 KB, patch)
2008-02-08 12:43 EST, Eric Sandeen
no flags Details | Diff
Updated patch (7.22 KB, patch)
2008-10-09 10:56 EDT, Eric Sandeen
no flags Details | Diff

  None (edit)
Description Eric Sandeen 2008-02-08 12:39:49 EST
system-config-lvm needs some smarts for ext4.  I did xfs too while I was at it,
will attach a patch.
Comment 1 Eric Sandeen 2008-02-08 12:43:19 EST
Created attachment 294387 [details]
initial patch

Here's a patch to implement ext4dev, xfs, and fix a "raiserfs" typo.

Note: ext4dev will at some point change to "ext4" so some changes will need to
be made at that point.

A test for the fully ext4-capable version of e2fsprogs would probably also be
good.

I felt a little bad with all the cut and paste; perhaps ext2/3/4 could use some
class inheritance?

If you'd like a simpler test for get_label, you could just call e2label rather
than parsing out tune2fs output.

Thanks,

-Eric
Comment 2 Jim Parsons 2008-03-28 23:56:27 EDT
This is very nice! Thanks kindly. I am in the middle of gitifying the s-c-lvm
repo, but will have all settled by early next week and will get this built.
Comment 3 Jon Stanley 2008-04-23 16:29:54 EDT
Adding FutureFeature keyword to RFE's.
Comment 4 Deji Akingunola 2008-10-09 10:26:31 EDT
Can the patch in comment #1 be applied before F-10 release. And given the latest update to the ext4 support, I believe all the reference to ext4dev can now be changed to ext4.
Comment 5 Eric Sandeen 2008-10-09 10:56:54 EDT
Created attachment 319868 [details]
Updated patch

Here's an updated patch.  This has been open for almost a year, is there a reason these changes can't be included?

Thanks,
-Eric
Comment 6 Deji Akingunola 2009-02-04 14:39:15 EST
Fedora 11 will default to ext4, it will great if this patch can be applied now. Thanks.

PS: If its OK with the package owner, I can go ahead and apply the patch, and build it in koji myself.
Comment 7 Jim Parsons 2009-02-04 16:30:49 EST
This patch is being included now. s-c-lvm is getting some much needed love. :) There are also a few /etc/fstab issues that are getting ironed out as well.
Comment 8 Eric Sandeen 2009-03-22 18:16:26 EDT
I wonder if there is anything else I can do (besides providing a patch over 1 year ago, and a subsequent updated patch...) to make this bug move.  ext4 is the default fs for F11, and s-c-lvm still doesn't recognize it.

Perhaps I could commit it to rawhide for you?

Thanks,
-Eric
Comment 9 Mike McLean 2009-05-01 15:46:11 EDT
another vote for making this work in F11. Seems kind of bad that it doesn't.
Comment 10 Eric Sandeen 2009-05-01 16:52:17 EDT
Jim, ping?
Comment 11 Robert Moles 2009-06-05 13:43:26 EDT
I have Preview Release F11 installed and still does not work. I have been allowing updates. Checked yum update system-config-lvm and none are available.
Comment 12 Eric Sandeen 2009-06-05 14:11:25 EDT
No, it won't work, the maintainer has not merged the provided patches.

Jim, perhaps you can just close this WONTFIX with an explanation of why, so people aren't left scratching their heads?  Because by now, I am too.
Comment 13 Mike McLean 2009-06-05 16:15:04 EDT
Seems like a good candidate for an update
Comment 14 Mike McLean 2009-06-05 16:35:28 EDT
Hi folks, Jim has promised a build by next week. Too late for the F11 drop, but an update is sufficient for fixing this.
Comment 15 Robert Moles 2009-06-22 13:29:27 EDT
Any status on this update?
Comment 16 Robert Moles 2009-06-22 20:50:05 EDT
Not sure if that was an update. But today I try running s-c-lvm and I get this.
[root@wolf ~]# system-config-lvm
Traceback (most recent call last):
  File "/usr/sbin/system-config-lvm", line 173, in <module>
    runFullGUI()
  File "/usr/sbin/system-config-lvm", line 158, in runFullGUI
    blvm = baselvm(glade_xml, app)
  File "/usr/sbin/system-config-lvm", line 108, in __init__
    self.volume_tab_view = Volume_Tab_View(glade_xml, self.lvmm, self.main_win)
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 133, in __init__
    self.prepare_tree()
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 214, in prepare_tree
    self.model_factory.reload()
  File "/usr/share/system-config-lvm/lvm_model.py", line 164, in reload
    self.__PVs = self.__query_partitions()
  File "/usr/share/system-config-lvm/lvm_model.py", line 198, in __query_partitions
    multipath_data = multipath_obj.get_multipath_data()
  File "/usr/share/system-config-lvm/Multipath.py", line 53, in get_multipath_data
    block_devices.append(['/dev/' + words[9], words[4].rstrip(','), words[5]])
IndexError: list index out of range

My current version is.system-config-lvm-1.1.4-5.1.fc11.noarch
Comment 17 Robert Moles 2009-06-22 20:51:03 EDT
Forgot to mention after I get this error then it dies.
Comment 18 Eric Sandeen 2009-06-29 15:49:04 EDT
I've requested commit access to s-c-l, maybe we can get it in that way if Jim approves.

-Eric
Comment 19 Eric Sandeen 2009-06-29 16:28:10 EDT
I've built w/ the patch and put a test rpm & srpm up at http://sandeen.fedorapeople.org/s-c-l/ if anyone wants to give it a whirl.
Comment 20 Clyde E. Kunkel 2009-06-29 21:10:15 EDT
YES!!  Works for me, can now see and create ext4 LVs.  Thank you, thank you, thank you.
Comment 21 Robert Moles 2009-07-04 21:04:31 EDT
Thank You Very Much. It works great. I was able to make new volumes, mount existing volumes with ext4.
Comment 22 David Highley 2009-07-07 11:55:35 EDT
This patch works for me as well.
Comment 23 Robert Moles 2009-07-22 20:00:39 EDT
Performed yum update and received system-config-lvm-1.1.4-6.fc12.noarch. This overwrote system-config-lvm-1.1.4-5.1.fc12.ers.noarch. The newer one does not work. Had to remove and place your fix back on. The one did not recognize ext4.
Comment 24 Eric Sandeen 2009-07-23 00:40:53 EDT
We seem to have a new maintainer for the package.  Hopefully the patch will get in -this- year ;)

-Eric
Comment 25 Eric Sandeen 2009-07-30 10:16:29 EDT
Hi Marek, welcome to the bug :)  A couple people have tested the patch and it seems to work, but i'm sure it could be cleaned up by someone who can write python better than me.  :)

Thanks,
-Eric
Comment 26 Marek Grac 2009-08-11 08:55:04 EDT
Hi,

Patch looks ok for me. Give me some time to build upstream

http://git.fedorahosted.org/git/system-config-lvm.git
Comment 27 Marek Grac 2009-08-11 08:56:40 EDT
*** Bug 508889 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.