This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 43216 - directory /usr/share is owned by this package
directory /usr/share is owned by this package
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: kdegraphics (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-01 17:28 EDT by Enrico Scholz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-01 17:28:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-06-01 17:28:29 EDT
[ created by { cat bug #43171 | sed 's!kdegames!kdegraphics!g' ; }  ;)   ]

Description of Problem:

The directory /usr/share is owned by this package which leads to an
installation-error if /usr/share is ro-mounted (e.g. via NFS):

| $ rpm -U /usr/src/redhat/RPMS/i386/kdegraphics-2.2-0.alpha2.1.i386.rpm
| error: unpacking of archive failed on file /usr/share: cpio: chown failed
- Read-only file system

Although this symptom is caused by an rpm error (see bug #26561), it is a
kdegraphics issue because no package (except filesystem) should own
/usr/share.

kdegraphics owns other directories also which should not be owned by normal
packages:

$ rpm -ql kdegraphics
...
/usr/bin
/usr/include
/usr/lib
/usr/share
/usr/share/doc


Steps to Reproduce:
1.  mount -o remount,ro /usr/share
2.  echo '%_netsharedpath /usr/share' >>/etc/rpm/macros
3.  rpm -U /usr/src/redhat/RPMS/i386/kdegraphics-2.2-0.alpha2.1.i386.rpm

Actual Results:

error: unpacking of archive failed on file /usr/share: cpio: chown failed -
Read-only file system

Expected Results:

installed kdegraphics


Additional Information:
	
$ rpm -q rpm
rpm-4.0.2-8
Comment 1 Bernhard Rosenkraenzer 2001-08-10 13:00:05 EDT
This was fixed quite a while ago, just forgot to close the bug report ;)

Note You need to log in before you can comment on or make changes to this bug.