Bug 432162 - Anaconda explodes when activating network interfaces in rescue mode
Anaconda explodes when activating network interfaces in rescue mode
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 444267 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-09 04:30 EST by Thomas Canniot
Modified: 2008-06-02 13:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-01 14:59:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Canniot 2008-02-09 04:30:22 EST
Description of problem:
I booted the DVD in rescue mode and replied "yes" when I was asked if I wanted
to activate network interfaces.
Then, anaconda explodes. (traceback)

The screen speaks about "/usr/lib/anaconda/textw/network_text.py in line 579 in
__call__", and in line 511 in chooseNetworkDevice;

Also :
UnicodeDecodeError : "'ascii' codec can't decode byte 0xc3 in position 17:
ordinal not in range(128)"

And the system halts.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. boot up the rescue cd or the dvd in rescue mode
2. reply yes when you are asked to activate network interfaces
Comment 1 Thomas Canniot 2008-02-09 04:40:00 EST
This bug also happens when you try to install Fedora in text mode, after the
choice of the language and the keyboard. You'll have a better output, however I
was not able to save it.
Comment 2 Johan Cwiklinski 2008-02-09 07:00:54 EST
Same problem here, trying to use the rescue cd
Comment 3 Thomas Müller 2008-04-23 02:27:32 EDT
Same here...

I bootet from Fedora-9-Preview-x86_64-netinst.iso, selected rescue mode and
german language and keyboard. When anaconda asked me if I wanted to configure
eth0 I selected yes.

Traceback (most recent call last):
File "/usr/bin/anaconda", line 788, in <module>
rescue.runRescue(anaconda, instClass)
File "/usr/lib/anaconda/rescue.py", line 252, in runRescue
rc = win(screen, anaconda, showonboot = 0)
File "/usr/lib/anaconda/textw/network_text.py", line 640, in __call__
rc = self.runMainScreen(screen, dev, showonboot)
File "/usr/lib/anaconda/textw/network_text.py", line 210, in runMainScreen
(dev.info['DEVICE']), "networkdev", 1, 5)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 23: ordinal
not in range(128)
install exited abnormally [1/1]
sending termination signals...done
...

This always happens when I select german, when I select english, everything
seems to work just fine.

Maybe this is some kind of localisation issue and python trips over an utf8
character?
Comment 4 Bug Zapper 2008-05-14 01:06:30 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Jeremy Katz 2008-05-29 16:27:53 EDT
Are you still seeing this with Fedora 9 final?
Comment 6 Thomas Müller 2008-05-31 05:40:38 EDT
nope, Fedora-9-x86_64-netinst.iso works fine here.
So this seems to be fixed.
Comment 7 Jeremy Katz 2008-06-01 14:59:33 EDT
Great, thanks for the confirmation
Comment 8 Andy Lindeberg 2008-06-02 13:02:06 EDT
*** Bug 444267 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.