Bug 432179 - SELinux is preventing the gdm-session-wor from using potentially mislabeled files (./.xsession-errors).
SELinux is preventing the gdm-session-wor from using potentially mislabeled f...
Status: CLOSED DUPLICATE of bug 431260
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-09 08:01 EST by Riku Seppala
Modified: 2015-01-14 18:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 18:52:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Riku Seppala 2008-02-09 08:01:39 EST
Summary:

SELinux is preventing the gdm-session-wor from using potentially mislabeled
files (./.xsession-errors).

Detailed Description:

SELinux has denied gdm-session-wor access to potentially mislabeled file(s)
(./.xsession-errors). This means that SELinux will not allow gdm-session-wor to
use these files. It is common for users to edit files in their home directory or
tmp directories and then move (mv) them to system directories. The problem is
that the files end up with the wrong file context which confined applications
are not allowed to access.

Allowing Access:

If you want gdm-session-wor to access this files, you need to relabel them using
restorecon -v './.xsession-errors'. You might want to relabel the entire
directory using restorecon -R -v '.'.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                ./.xsession-errors [ file ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           gdm-2.21.6-1.fc9
Target RPM Packages
Policy RPM                    selinux-policy-3.2.7-1.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   home_tmp_bad_labels
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain 2.6.24-23.fc9 #1 SMP
                              Wed Feb 6 11:23:06 EST 2008 x86_64 x86_64
Alert Count                   7
First Seen                    Fri 08 Feb 2008 12:29:32 PM EET
Last Seen                     Fri 08 Feb 2008 10:32:52 PM EET
Local ID                      446d3d9c-cff3-463e-b196-ccc98b63781a
Line Numbers

Raw Audit Messages

host=localhost.localdomain type=AVC msg=audit(1202502772.945:15): avc:  denied 
{ append } for  pid=2847 comm="gdm-session-wor" name=".xsession-errors" dev=dm-0
ino=2812663 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:object_r:admin_home_t:s0 tclass=file

host=localhost.localdomain type=SYSCALL msg=audit(1202502772.945:15):
arch=c000003e syscall=2 success=no exit=-13 a0=6292b0 a1=442 a2=180 a3=0 items=0
ppid=2763 pid=2847 auid=0uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0
tty=(none) comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker"
subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)
Comment 1 jmccann 2008-03-07 18:52:12 EST

*** This bug has been marked as a duplicate of 431260 ***

Note You need to log in before you can comment on or make changes to this bug.