Bug 432238 - It is not possible change the reporter of the bug when the original one is MIA
It is not possible change the reporter of the bug when the original one is MIA
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
2.18
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-10 05:11 EST by Matěj Cepl
Modified: 2013-06-23 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-10 21:48:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2008-02-10 05:11:28 EST
Description of problem:
see bug 212616 -- the original reporter went MIA and when Jan Pazdziora (of Brno
office) confirmed he can reproduce the bug, I would love to change the
"reportership" of the bug to him. Now he can fix this by cloning the bug, but a)
it is awkward, b) when bug 213310 is fixed, this won't work either.
Comment 1 David Lawrence 2008-02-10 21:45:09 EST
This is original design of Bugzilla and it escapes me right now what the
original intention was to not allow changing of the reporter of a bug. But we do
have a XMLRPC method that can do this. 

bugzilla.changeAssignment($bugid, { reporter => jpazdziora@redhat.com },
$username, $password);

I will do that for the bug in question.

Dave
Comment 2 Jan Pazdziora 2008-02-11 02:55:53 EST
Well, reporter is just that -- the person who reported the bug. There is no real
reason to change that information. As for bug 212616, since I learned about the
existence of that bug, I put myself to Cc, so that I would catch and answer all
NEEDINFO requests anyway.
Comment 3 Matěj Cepl 2008-02-11 08:08:32 EST
(In reply to comment #2)
> Well, reporter is just that -- the person who reported the bug. There is no real
> reason to change that information. As for bug 212616, since I learned about the
> existence of that bug, I put myself to Cc, so that I would catch and answer all
> NEEDINFO requests anyway.

I am sorry, Jan, but I have to very respectfully disagree with you. Bugzilla is
not a tool for theoretical discussion about the True Nature of reporter, but a
tool for management of our work. In this respect, a reporter is somebody who
will answer my questions, who is willing to reproduce a bug, and who will
confirm that the bug is patched.

Need to remember, that "this reporter is MIA, and I should communicate with a
guy on Cc: list" (and set NEEDINFO accordingly) ... that just doesn't scale.

Comment 4 Jan Pazdziora 2008-02-11 08:20:48 EST
I provided the info needed in bug 212616, didn't I?

Any communication you do goes via bugzilla comments, you don't communicate with
a guy on Cc: list. And I follow the comments. It was you who missed my answer.

Your point?

Note You need to log in before you can comment on or make changes to this bug.