Bug 432269 - Colours changed/twisted after resuming session
Colours changed/twisted after resuming session
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: freenx-server (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-10 14:14 EST by markus
Modified: 2008-07-26 02:04 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.7.2-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 03:42:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
When session is resumed, and colour turn strange. (139.58 KB, image/png)
2008-02-10 14:16 EST, markus
no flags Details
Screendump of the server screen done at the server which shows the correct colours (65.82 KB, image/png)
2008-02-10 14:20 EST, markus
no flags Details

  None (edit)
Description markus 2008-02-10 14:14:31 EST
From Bugzilla Helper:
User-Agent: Opera/9.50 (X11; Linux x86_64; U; en)

Description of problem:
This is the first of a series of problems.

When resuming my nx session colours are changed. The menu text usualy turns 
green, and the shadow on the desktop text is sometimes strange too.

I've made two screen-dumps: On on the server, and one on the client. The server 
one looks as expected, and the client one shows the problem.

This problem is present with both windows client and linux client (using 
nomachines client in both cases)

Version-Release number of selected component (if applicable):
freenx-0.7.1-3.fc8

How reproducible:
Always


Steps to Reproduce:
1. Create session
2. Suspend session
3. Reconnect to session

Actual Results:
Some colours are changed. There are many examples, and it never seems to be 
exacty the same.

Expected Results:
The desktop should look as when connecting the first time.

Additional info:
Comment 1 markus 2008-02-10 14:16:24 EST
Created attachment 294505 [details]
When session is resumed, and colour turn strange.
Comment 2 markus 2008-02-10 14:20:10 EST
Created attachment 294506 [details]
Screendump of the server screen done at the server which shows the correct colours
Comment 3 Axel Thimm 2008-04-11 12:20:40 EDT
This is a collective comment for freenx bugs. There is a new release packaged as
freenx-server-0.7.2-7 in rawhide and soon in updates-testing. Please test it and
see whether it fixed your report.

Also note that freenx has been split into freenx-server and freenx-client. All
current open bug reports will move to freenx-server once it is created in bugzilla.
Comment 4 markus 2008-04-17 13:05:05 EDT
Hi.

Sorry to have to bug you about this.... I tried to install fedora-server-0.7.2-
7 from updates testing and I keep getting this message:

Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package freenx-server.i386 0:0.7.2-7.fc8 set to be updated
--> Processing Dependency: nx for package: freenx-server
--> Processing Dependency: /usr/share/nx for package: freenx-server
--> Processing Dependency: /usr/lib/nx for package: freenx-server
--> Running transaction check
---> Package freenx-server.i386 0:0.7.2-7.fc8 set to be updated
--> Processing Dependency: /usr/share/nx for package: freenx-server
---> Package nx.i386 0:3.1.0-25.1.fc8 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: /usr/share/nx is needed by package freenx-server

Any ideas?
Comment 5 Axel Thimm 2008-04-24 04:37:42 EDT
freenx has been split into freenx-server and freenx-client. Most open bugs for
freenx addressed parts of the current freenx-server package. See also bug #438660.

freenx-server is currently in testing repos. Please give it a try as it will
soon replace the freenx package.
Comment 6 Axel Thimm 2008-04-24 07:17:17 EDT
(In reply to comment #4)
> I tried to install fedora-server-0.7.2-7 from updates testing and I keep
getting this message:
> Error: Missing Dependency: /usr/share/nx is needed by package freenx-server

This is bug #443329, which is fixed with fedora-server-0.7.2-8.
Comment 7 markus 2008-04-25 11:24:11 EDT
Seems to be fixed! Happend almost every time before. I have tried a lot of 
times, under various server loads, and I can't get it to happen.

By the way: I had a lot of problem at first getting freenx-server to reconnect 
to a suspened session at first. The client connected, showed the remote desktop 
but disconnected 3 minutes later. I solved the problem by clearing out all 
cache files on the client side. I suspect this have to do with me using the 
Nomachine nx server before.
Comment 8 Axel Thimm 2008-04-30 03:42:02 EDT
Thanks for reporting and the feedback!
Comment 9 Fedora Update System 2008-05-10 09:56:43 EDT
freenx-server-0.7.2-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2008-05-13 11:29:45 EDT
freenx-server-0.7.2-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-07-26 02:04:56 EDT
freenx-server-0.7.2-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.